libauthen-radius-perl_0.22.bb 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. SUMMARY = "Authen::Radius - provide simple Radius client facilities"
  2. DESCRIPTION = "The Authen::Radius module provides a simple class that \
  3. allows you to send/receive Radius requests/responses to/from a \
  4. Radius server. \
  5. "
  6. HOMEPAGE = "http://search.cpan.org/~manowar/RadiusPerl"
  7. SECTION = "libs"
  8. LICENSE = "Artistic-2.0"
  9. LIC_FILES_CHKSUM = "file://LICENSE;md5=78ab6ea0cba1f1ec1680ebb149e3bc11"
  10. DEPENDS = "perl"
  11. SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MANOWAR/RadiusPerl-${PV}.tar.gz \
  12. file://test.pl-adjust-for-ptest.patch \
  13. file://run-ptest \
  14. "
  15. SRC_URI[md5sum] = "d1fe2d6ecf7ea99299e4e3a8f945aad8"
  16. SRC_URI[sha256sum] = "3b276506986ccaa4949d92b13ce053a0017ad11562a991cc753364923fe81ca7"
  17. S = "${WORKDIR}/Authen-Radius-${PV}"
  18. inherit cpan ptest
  19. do_install_ptest() {
  20. install -m 0755 ${S}/test.pl ${D}${PTEST_PATH}
  21. }
  22. RDEPENDS_${PN} += "\
  23. libdata-hexdump-perl \
  24. perl-module-digest-md5 \
  25. perl-module-data-dumper \
  26. perl-module-io-select \
  27. perl-module-io-socket \
  28. "
  29. RDEPENDS_${PN}-ptest += " \
  30. ${@bb.utils.contains('PTEST_ENABLED', '1', 'freeradius', '', d)} \
  31. "
  32. BBCLASSEXTEND = "native"
  33. python() {
  34. if bb.utils.contains('PTEST_ENABLED', '1', 'True', 'False', d) and \
  35. 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
  36. raise bb.parse.SkipRecipe('ptest requires meta-networking to be present.')
  37. }