Kaynağa Gözat

libcec: split the python example into a separate package

It does not provide more functionality than the C-based examples, so
is of little value on a target except for checking the python module
is working.

Signed-off-by: Yann Dirson <yann@blade-group.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Yann Dirson 3 yıl önce
ebeveyn
işleme
58ba034db7

+ 4 - 3
meta-oe/recipes-extended/libcec/libcec_6.0.2.bb

@@ -24,10 +24,11 @@ inherit cmake pkgconfig
 PLATFORM_CMAKE_FLAGS ?= "-DHAVE_LINUX_API=1 -DHAVE_RPI_API=0"
 EXTRA_OECMAKE += "${PLATFORM_CMAKE_FLAGS}"
 
-# Put client examples into a separate package
-PACKAGE_BEFORE_PN += "${PN}-examples"
+# Put client examples into separate packages
+PACKAGE_BEFORE_PN += "${PN}-examples-python ${PN}-examples"
+FILES_${PN}-examples-python = "${bindir}/py*"
 FILES_${PN}-examples = "${bindir}"
-RDEPENDS_${PN}-examples = "python3-${BPN} python3-core"
+RDEPENDS_${PN}-examples-python = "python3-${BPN} python3-core"
 
 # Create the wrapper for python3
 PACKAGES += "python3-${BPN}"