Explorar el Código

emlog: Do not clean modules when building apps

Fixes
make -C /lib/modules/5.5.13-arch1-1/build M=/mnt/b/yoe/build/tmp/work/core2-64-yoe-linux/emlog/git-r0/git clean
make[1]: *** /lib/modules/5.5.13-arch1-1/build: No such file or directory.  Stop.
make: *** [Makefile:36: modules_clean] Error 2

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj hace 4 años
padre
commit
4cb9812277

+ 33 - 0
meta-oe/recipes-core/emlog/emlog/0001-Remove-modules_clean-from-clean-target.patch

@@ -0,0 +1,33 @@
+From fd0a4ee201b5c7b24da79dcd346ac121978951a0 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 29 Mar 2020 19:58:36 -0700
+Subject: [PATCH] Remove modules_clean from clean target
+
+This is needed when building applications (w/o module)
+Since OE will run 'make clean' before reconfiguring, this
+will try to run module_clean and will wrongly try to look for removing
+modules from /lib/modules
+
+Upstream-Status: Inappropriate [ OE-Specific ]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index c60863f..fc897d5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,7 +23,7 @@ all: modules nbcat mkemlog
+ 
+ install: modules_install nbcat_install mkemlog_install
+ 
+-clean: modules_clean nbcat_clean mkemlog_clean
++clean: nbcat_clean mkemlog_clean
+ 
+ modules:
+ 	$(MAKE) -C $(KDIR) M=$(CURDIR) modules
+-- 
+2.26.0
+

+ 5 - 1
meta-oe/recipes-core/emlog/emlog_git.bb

@@ -1,6 +1,8 @@
 require ${BPN}.inc
 
-SRC_URI += "file://${BPN}.initd"
+SRC_URI += "file://${BPN}.initd \
+            file://0001-Remove-modules_clean-from-clean-target.patch \
+            "
 
 SRC_URI_append_libc-musl = " file://Drop-use-of-error-h.patch"
 
@@ -8,6 +10,8 @@ inherit update-rc.d
 
 INITSCRIPT_NAME = "${BPN}"
 
+
+
 do_compile() {
     oe_runmake nbcat
     oe_runmake mkemlog