emlog_git.bb 560 B

1234567891011121314151617181920212223242526
  1. require ${BPN}.inc
  2. SRC_URI += "file://${BPN}.initd \
  3. file://0001-Remove-modules_clean-from-clean-target.patch \
  4. "
  5. SRC_URI_append_libc-musl = " file://Drop-use-of-error-h.patch"
  6. inherit update-rc.d
  7. INITSCRIPT_NAME = "${BPN}"
  8. do_compile() {
  9. oe_runmake nbcat
  10. oe_runmake mkemlog
  11. }
  12. do_install() {
  13. install -Dm 0755 ${WORKDIR}/${BPN}.initd ${D}${sysconfdir}/init.d/${BPN}
  14. install -Dm 0755 ${S}/nbcat ${D}${bindir}/nbcat
  15. install -Dm 0755 ${S}/mkemlog ${D}${bindir}/mkemlog
  16. }
  17. RRECOMMENDS_${PN} += "kernel-module-emlog"