Przeglądaj źródła

recipes: Inherit missing texinfo for makeinfo program

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 4 lat temu
rodzic
commit
4078a203e8

+ 1 - 1
meta-oe/recipes-devtools/cgdb/cgdb_0.7.1.bb

@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 
 DEPENDS = "flex-native readline ncurses"
 
-inherit autotools
+inherit autotools texinfo
 
 SRC_URI = "http://cgdb.me/files/${BP}.tar.gz \
            file://0001-Avoid-use-of-mips-which-is-reserved-on-mips.patch \

+ 1 - 2
meta-oe/recipes-extended/indent/indent_2.2.12.bb

@@ -9,7 +9,6 @@ Install the indent package if you are developing applications in C and \
 you want a program to format your code."
 LICENSE = "GPLv3"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-DEPENDS = "virtual/gettext"
 
 SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
            file://0001-src-indent.c-correct-the-check-for-locale.h.patch \
@@ -19,7 +18,7 @@ SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
 SRC_URI[md5sum] = "4764b6ac98f6654a35da117b8e5e8e14"
 SRC_URI[sha256sum] = "e77d68c0211515459b8812118d606812e300097cfac0b4e9fb3472664263bb8b"
 
-inherit autotools gettext
+inherit autotools gettext texinfo
 
 CFLAGS_class-native += " -Wno-error=unused-value"
 

+ 1 - 1
meta-oe/recipes-extended/nana/nana_2.5.bb

@@ -15,7 +15,7 @@ LICENSE = "BSD-2-Clause"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=16aa57f3b7fdda870cee597275bd5d11"
 
-inherit autotools-brokensep pkgconfig
+inherit autotools-brokensep pkgconfig texinfo
 
 EXTRA_OEMAKE = "DESTDIR=${D}"
 

+ 1 - 1
meta-oe/recipes-support/gengetopt/gengetopt_2.23.bb

@@ -11,6 +11,6 @@ SRC_URI = "${GNU_MIRROR}/gengetopt/${BPN}-${PV}.tar.xz"
 SRC_URI[md5sum] = "ea165d618640dbdecb42ae4491337965"
 SRC_URI[sha256sum] = "b941aec9011864978dd7fdeb052b1943535824169d2aa2b0e7eae9ab807584ac"
 
-inherit autotools
+inherit autotools texinfo
 
 BBCLASSEXTEND = "native nativesdk"

+ 1 - 1
meta-oe/recipes-support/gpm/gpm_git.bb

@@ -21,7 +21,7 @@ SRC_URI = "git://github.com/telmich/gpm;protocol=git \
 
 S = "${WORKDIR}/git"
 
-inherit autotools-brokensep update-rc.d systemd
+inherit autotools-brokensep update-rc.d systemd texinfo
 
 INITSCRIPT_NAME = "gpm"
 INITSCRIPT_PARAMS = "defaults"

+ 1 - 1
meta-oe/recipes-support/iksemel/iksemel_1.5.bb

@@ -13,7 +13,7 @@ SRC_URI = "git://github.com/meduketto/iksemel.git;protocol=https \
 
 S = "${WORKDIR}/git"
 
-inherit autotools pkgconfig lib_package
+inherit autotools pkgconfig lib_package texinfo
 
 # TLS support requires either openssl or gnutls (if both are enabled openssl will be used).
 PACKAGECONFIG ?= "gnutls"