gpm_git.bb 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. SUMMARY = "Console mouse driver"
  2. DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
  3. for the console and xterm, with sample clients included \
  4. (emacs, etc)."
  5. HOMEPAGE = "https://www.nico.schottelius.org/software/gpm"
  6. SECTION = "console/utils"
  7. LICENSE = "GPLv2+"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
  9. PV = "1.99.7+git${SRCREV}"
  10. PR = "r2"
  11. SRCREV = "1fd19417b8a4dd9945347e98dfa97e4cfd798d77"
  12. DEPENDS = "ncurses bison-native"
  13. SRC_URI = "git://github.com/telmich/gpm;protocol=git \
  14. file://init \
  15. file://gpm.service.in \
  16. file://0001-Use-sigemptyset-API-instead-of-__sigemptyset.patch \
  17. "
  18. S = "${WORKDIR}/git"
  19. inherit autotools-brokensep update-rc.d systemd texinfo
  20. INITSCRIPT_NAME = "gpm"
  21. INITSCRIPT_PARAMS = "defaults"
  22. do_configure_prepend() {
  23. (cd ${S};./autogen.sh;cd -)
  24. }
  25. do_install_append () {
  26. install -d ${D}${systemd_system_unitdir}
  27. sed 's:@bindir@:${sbindir}:' < ${WORKDIR}/gpm.service.in >${D}${systemd_system_unitdir}/gpm.service
  28. install -D -m 0755 ${WORKDIR}/init ${D}${INIT_D_DIR}/gpm
  29. ln -s libgpm.so.2 ${D}${libdir}/libgpm.so
  30. }
  31. SYSTEMD_SERVICE_${PN} = "gpm.service"