Browse Source

jack: Upgrade to 1.19.16

Update the jack_simdtests patch to latest submission upstream
Fix build on RISCV32

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 3 years ago
parent
commit
2eedfe5001

+ 62 - 0
meta-oe/recipes-multimedia/jack/jack/0001-Use-SYS_futex-instead-of-__NR_futex.patch

@@ -0,0 +1,62 @@
+From 83068f9b71aea16d1ad036fdcc326de1027b5585 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 15 Nov 2020 22:13:29 -0800
+Subject: [PATCH] Use SYS_futex instead of __NR_futex
+
+SYS_futex is expected from system C library.
+in glibc (/usr/include/bits/syscall.h defines it in terms of of NR_futex)
+rv32 is using 64bit time_t from get go unlike other 32bit architectures
+in glibc, therefore it wont have NR_futex defined but just NR_futex_time64
+this aliases it to NR_futex so that SYS_futex is then defined for rv32
+
+Upstream-Status: Submitted [https://github.com/jackaudio/jack2/pull/670]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ linux/JackLinuxFutex.cpp | 10 +++++++---
+ 1 file changed, 7 insertions(+), 3 deletions(-)
+
+diff --git a/linux/JackLinuxFutex.cpp b/linux/JackLinuxFutex.cpp
+index deff006b..aef99cd2 100644
+--- a/linux/JackLinuxFutex.cpp
++++ b/linux/JackLinuxFutex.cpp
+@@ -29,6 +29,10 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #include <syscall.h>
+ #include <linux/futex.h>
+ 
++#if !defined(SYS_futex) && defined(SYS_futex_time64)
++#define SYS_futex SYS_futex_time64
++#endif
++
+ namespace Jack
+ {
+ 
+@@ -67,7 +71,7 @@ bool JackLinuxFutex::Signal()
+         if (! fFutex->internal) return true;
+     }
+ 
+-    ::syscall(__NR_futex, fFutex, fFutex->internal ? FUTEX_WAKE_PRIVATE : FUTEX_WAKE, 1, NULL, NULL, 0);
++    ::syscall(SYS_futex, fFutex, fFutex->internal ? FUTEX_WAKE_PRIVATE : FUTEX_WAKE, 1, NULL, NULL, 0);
+     return true;
+ }
+ 
+@@ -94,7 +98,7 @@ bool JackLinuxFutex::Wait()
+         if (__sync_bool_compare_and_swap(&fFutex->futex, 1, 0))
+             return true;
+ 
+-        if (::syscall(__NR_futex, fFutex, fFutex->internal ? FUTEX_WAIT_PRIVATE : FUTEX_WAIT, 0, NULL, NULL, 0) != 0 && errno != EWOULDBLOCK)
++        if (::syscall(SYS_futex, fFutex, fFutex->internal ? FUTEX_WAIT_PRIVATE : FUTEX_WAIT, 0, NULL, NULL, 0) != 0 && errno != EWOULDBLOCK)
+             return false;
+     }
+ }
+@@ -122,7 +126,7 @@ bool JackLinuxFutex::TimedWait(long usec)
+         if (__sync_bool_compare_and_swap(&fFutex->futex, 1, 0))
+             return true;
+ 
+-        if (::syscall(__NR_futex, fFutex, fFutex->internal ? FUTEX_WAIT_PRIVATE : FUTEX_WAIT, 0, &timeout, NULL, 0) != 0 && errno != EWOULDBLOCK)
++        if (::syscall(SYS_futex, fFutex, fFutex->internal ? FUTEX_WAIT_PRIVATE : FUTEX_WAIT, 0, &timeout, NULL, 0) != 0 && errno != EWOULDBLOCK)
+             return false;
+     }
+ }
+-- 
+2.29.2
+

+ 17 - 13
meta-oe/recipes-multimedia/jack/jack/0001-example-clients-Use-c-compiler-for-jack_simdtests.patch

@@ -1,4 +1,4 @@
-From 76b8a389268275cc13f3b4e61394d40b24ec56f1 Mon Sep 17 00:00:00 2001
+From f8cb818ca96fc2a45a04448a51f25a277ec183db Mon Sep 17 00:00:00 2001
 From: Khem Raj <raj.khem@gmail.com>
 Date: Wed, 15 Jan 2020 20:21:58 -0800
 Subject: [PATCH] example-clients: Use c++ compiler for jack_simdtests
@@ -12,22 +12,26 @@ x86_64-yoe-linux-ld: example-clients/simdtests.cpp.28.o: undefined reference to
 Upstream-Status: Submitted [https://github.com/jackaudio/jack2/pull/536]
 Signed-off-by: Khem Raj <raj.khem@gmail.com>
 ---
- example-clients/wscript | 2 ++
- 1 file changed, 2 insertions(+)
+ example-clients/wscript | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
 
-diff --git a/example-clients/wscript b/example-clients/wscript
-index a8857aa7..df9435aa 100644
 --- a/example-clients/wscript
 +++ b/example-clients/wscript
-@@ -69,6 +69,8 @@ def build(bld):
+@@ -49,10 +49,15 @@ def build(bld):
+         else:
+             use = ['clientlib']
  
++        if example_program == 'jack_simdtests':
++            ftrs = 'cxx cxxprogram'
++        else:
++            ftrs = 'c cprogram'
++
          if bld.env['IS_MACOSX']:
-             prog = bld(features='c cprogram', framework = ['Foundation'])
-+        elif example_program == 'jack_simdtests':
-+            prog = bld(features='cxx cxxprogram')
+-            prog = bld(features='c cprogram', framework = ['Foundation'])
++            prog = bld(features = ftrs, framework = ['Foundation'])
          else:
-             prog = bld(features='c cprogram')
+-            prog = bld(features='c cprogram')
++            prog = bld(features = ftrs)
          prog.includes = os_incdir + ['../common/jack', '../common']
--- 
-2.25.0
-
+         prog.source = example_program_source
+         prog.use = use

+ 2 - 1
meta-oe/recipes-multimedia/jack/jack_1.19.14.bb → meta-oe/recipes-multimedia/jack/jack_1.19.16.bb

@@ -16,8 +16,9 @@ DEPENDS = "libsamplerate0 libsndfile1 readline"
 
 SRC_URI = "git://github.com/jackaudio/jack2.git \
            file://0001-example-clients-Use-c-compiler-for-jack_simdtests.patch \
+           file://0001-Use-SYS_futex-instead-of-__NR_futex.patch \
           "
-SRCREV = "b54a09bf7ef760d81fdb8544ad10e45575394624"
+SRCREV = "5b78c2ef158c2d9ffe09818a7dd80209ed251c5f"
 
 S = "${WORKDIR}/git"