jack_1.19.16.bb 1.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
  2. server for multi-processor machines. It is a new implementation of the \
  3. JACK server core features that aims in removing some limitations of \
  4. the JACK1 design. The activation system has been changed for a data \
  5. flow model and lock-free programming techniques for graph access have \
  6. been used to have a more dynamic and robust system."
  7. SECTION = "libs/multimedia"
  8. LICENSE = "GPLv2 & LGPLv2.1"
  9. LIC_FILES_CHKSUM = " \
  10. file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \
  11. file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \
  12. "
  13. DEPENDS = "libsamplerate0 libsndfile1 readline"
  14. SRC_URI = "git://github.com/jackaudio/jack2.git \
  15. file://0001-example-clients-Use-c-compiler-for-jack_simdtests.patch \
  16. file://0001-Use-SYS_futex-instead-of-__NR_futex.patch \
  17. "
  18. SRCREV = "5b78c2ef158c2d9ffe09818a7dd80209ed251c5f"
  19. S = "${WORKDIR}/git"
  20. inherit waf pkgconfig
  21. PACKAGECONFIG ??= "alsa"
  22. PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib"
  23. # --dbus only stops building jackd -> add --classic
  24. PACKAGECONFIG[dbus] = "--dbus --classic,,dbus"
  25. PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus"
  26. # portaudio is for windows builds only
  27. EXTRA_OECONF = "--portaudio=no"
  28. do_install_append() {
  29. if ! ${@bb.utils.contains('PACKAGECONFIG', 'dbus', True, False, d)}; then
  30. rm -f ${D}${bindir}/jack_control
  31. fi
  32. }
  33. PACKAGES =+ "libjack jack-server jack-utils"
  34. RDEPENDS_jack-dev_remove = "${PN} (= ${EXTENDPKGV})"
  35. FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
  36. FILES_jack-server = " \
  37. ${datadir}/dbus-1/services \
  38. ${bindir}/jackdbus \
  39. ${bindir}/jackd \
  40. "
  41. FILES_jack-utils = "${bindir}/*"
  42. FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/*"