Quellcode durchsuchen

id3lib: Make sure that quilt-native is staged

id3lib_do_patch needs quilt to be built for it to run

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj vor 4 Jahren
Ursprung
Commit
1ba4d9baa9
1 geänderte Dateien mit 4 neuen und 3 gelöschten Zeilen
  1. 4 3
      meta-oe/recipes-multimedia/id3lib/id3lib_3.8.3.bb

+ 4 - 3
meta-oe/recipes-multimedia/id3lib/id3lib_3.8.3.bb

@@ -21,6 +21,7 @@ inherit autotools
 # patches maintained by quilt. So manually apply them before applying other local
 # patches. Also remove all temp files before leaving, because do_patch() will pop
 # up all previously applied patches in the start
+do_patch[depends] += "quilt-native:do_populate_sysroot"
 id3lib_do_patch() {
     cd ${S}
     # it's important that we only pop the existing patches when they've
@@ -33,14 +34,14 @@ id3lib_do_patch() {
         # the test inside which we operate
         QUILT_PATCHES=${S}/patches quilt pop -a
     fi
-    if [ -d ${S}/.pc-id3lib ]; then
+    if [ -d ${S}/.pc-${BPN} ]; then
         rm -rf ${S}/.pc
-        mv ${S}/.pc-id3lib ${S}/.pc
+        mv ${S}/.pc-${BPN} ${S}/.pc
         QUILT_PATCHES=${S}/debian/patches quilt pop -a
         rm -rf ${S}/.pc ${S}/debian
     fi
     QUILT_PATCHES=${S}/debian/patches quilt push -a
-    mv ${S}/.pc ${S}/.pc-id3lib
+    mv ${S}/.pc ${S}/.pc-${BPN}
 }
 
 do_unpack[cleandirs] += "${S}"