id3lib_3.8.3.bb 2.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. SUMMARY = "Library for interacting with ID3 tags"
  2. SECTION = "libs/multimedia"
  3. LICENSE = "LGPLv2+"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
  5. DEPENDS = "zlib"
  6. PR = "r1"
  7. SRC_URI = "${SOURCEFORGE_MIRROR}/id3lib/id3lib-${PV}.tar.gz;name=archive \
  8. ${DEBIAN_MIRROR}/main/i/id3lib3.8.3/id3lib3.8.3_3.8.3-16.2.debian.tar.xz;name=patch;subdir=${BP} \
  9. file://acdefine.patch \
  10. "
  11. SRC_URI[archive.md5sum] = "19f27ddd2dda4b2d26a559a4f0f402a7"
  12. SRC_URI[archive.sha256sum] = "2749cc3c0cd7280b299518b1ddf5a5bcfe2d1100614519b68702230e26c7d079"
  13. SRC_URI[patch.md5sum] = "997c764d3be11c9a51779d93facf1118"
  14. SRC_URI[patch.sha256sum] = "ac2ee23ec89ba2af51d2c6dd5b1b6bf9f8a9f813de251bc182941439a4053176"
  15. inherit autotools
  16. # Unlike other Debian packages, id3lib*.diff.gz contains another series of
  17. # patches maintained by quilt. So manually apply them before applying other local
  18. # patches. Also remove all temp files before leaving, because do_patch() will pop
  19. # up all previously applied patches in the start
  20. do_patch[depends] += "quilt-native:do_populate_sysroot"
  21. id3lib_do_patch() {
  22. cd ${S}
  23. # it's important that we only pop the existing patches when they've
  24. # been applied, otherwise quilt will climb the directory tree
  25. # and reverse out some completely different set of patches
  26. if [ -d ${S}/patches ]; then
  27. # whilst this is the default directory, doing it like this
  28. # defeats the directory climbing that quilt will otherwise
  29. # do; note the directory must exist to defeat this, hence
  30. # the test inside which we operate
  31. QUILT_PATCHES=${S}/patches quilt pop -a
  32. fi
  33. if [ -d ${S}/.pc-${BPN} ]; then
  34. rm -rf ${S}/.pc
  35. mv ${S}/.pc-${BPN} ${S}/.pc
  36. QUILT_PATCHES=${S}/debian/patches quilt pop -a
  37. rm -rf ${S}/.pc ${S}/debian
  38. fi
  39. QUILT_PATCHES=${S}/debian/patches quilt push -a
  40. mv ${S}/.pc ${S}/.pc-${BPN}
  41. }
  42. do_unpack[cleandirs] += "${S}"
  43. # We invoke base do_patch at end, to incorporate any local patch
  44. python do_patch() {
  45. bb.build.exec_func('id3lib_do_patch', d)
  46. bb.build.exec_func('patch_do_patch', d)
  47. }