Explorar el Código

cdrkit: split into more packages

Mimic the Debian pacaking scheme to allow for more fine-grained
installation choice (install the binaries we need). Moreover, dirsplit
was moved to a separate package, as it pulls in perl interpreter.

Signed-off-by: Maciej Pijanowski <maciej.pijanowski@3mdeb.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Maciej Pijanowski hace 3 años
padre
commit
167592e635

+ 4 - 1
meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb

@@ -615,7 +615,10 @@ RDEPENDS_packagegroup-meta-oe-kernel_remove_riscv32 = "crash makedumpfile oprofi
 RDEPENDS_packagegroup-meta-oe-multimedia ="\
     alsa-oss \
     ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "faad2", "", d)} \
-    cdrkit \
+    dirsplit \
+    genisoimage \
+    icedax \
+    wodim \
     id3lib \
     audiofile \
     a2jmidid \

+ 31 - 1
meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb

@@ -18,7 +18,37 @@ SRC_URI[sha256sum] = "d1c030756ecc182defee9fe885638c1785d35a2c2a297b4604c0e0dcc7
 inherit cmake
 
 DEPENDS = "libcap file bzip2"
-RDEPENDS_${PN} = "perl"
+RDEPENDS_dirsplit = "perl"
+
+PACKAGES =+ "dirsplit genisoimage icedax wodim"
+
+FILES_dirsplit = " \
+    ${bindir}/dirsplit \
+"
+
+FILES_genisoimage = " \
+    ${bindir}/devdump \
+    ${bindir}/genisoimage \
+    ${bindir}/isodebug \
+    ${bindir}/isodump \
+    ${bindir}/isoinfo \
+    ${bindir}/isovfy \
+    ${bindir}/mkisofs \
+"
+
+FILES_icedax = " \
+    ${bindir}/cdda2mp3 \
+    ${bindir}/cdda2ogg \
+    ${bindir}/icedax \
+    ${bindir}/pitchplay \
+    ${bindir}/readmult \
+"
+
+FILES_wodim = " \
+    ${bindir}/readom \
+    ${bindir}/wodim \
+    ${sbindir}/netscsid \
+"
 
 do_install_append() {
     ln -sf ${bindir}/genisoimage ${D}${bindir}/mkisofs