cdrkit_1.1.11.bb 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. SUMMARY = "CD/DVD command line tools"
  2. HOMEPAGE = "http://cdrkit.org/"
  3. LICENSE = "GPLv2"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=b30d3b2750b668133fc17b401e1b98f8"
  5. # While writing download from cdrkit.org was broken so get sources from debian
  6. SRC_URI = "${DEBIAN_MIRROR}/main/c/${BPN}/${BPN}_${PV}.orig.tar.gz \
  7. file://0001-do-not-create-a-run-test-to-determine-order-of-bitfi.patch \
  8. file://0001-genisoimage-Fix-fprintf-format-errors.patch \
  9. file://0001-define-__THROW-to-avoid-build-issue-with-musl.patch \
  10. file://0002-Do-not-use-rcmd-on-build-with-musl.patch \
  11. file://0001-genisoimage-Add-missing-extern-definition.patch \
  12. "
  13. SRC_URI[md5sum] = "efe08e2f3ca478486037b053acd512e9"
  14. SRC_URI[sha256sum] = "d1c030756ecc182defee9fe885638c1785d35a2c2a297b4604c0e0dcc78e47da"
  15. inherit cmake
  16. DEPENDS = "libcap file bzip2"
  17. RDEPENDS_dirsplit = "perl"
  18. PACKAGES =+ "dirsplit genisoimage icedax wodim"
  19. FILES_dirsplit = " \
  20. ${bindir}/dirsplit \
  21. "
  22. FILES_genisoimage = " \
  23. ${bindir}/devdump \
  24. ${bindir}/genisoimage \
  25. ${bindir}/isodebug \
  26. ${bindir}/isodump \
  27. ${bindir}/isoinfo \
  28. ${bindir}/isovfy \
  29. ${bindir}/mkisofs \
  30. "
  31. FILES_icedax = " \
  32. ${bindir}/cdda2mp3 \
  33. ${bindir}/cdda2ogg \
  34. ${bindir}/icedax \
  35. ${bindir}/pitchplay \
  36. ${bindir}/readmult \
  37. "
  38. FILES_wodim = " \
  39. ${bindir}/readom \
  40. ${bindir}/wodim \
  41. ${sbindir}/netscsid \
  42. "
  43. do_install_append() {
  44. ln -sf ${bindir}/genisoimage ${D}${bindir}/mkisofs
  45. }
  46. BBCLASSEXTEND = "native"