Selaa lähdekoodia

pointercal: move recipe from oe-core

Move pointercal recipe from oe-core layer.

Signed-off-by: Maxin B. John <maxin.john@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Maxin B. John 7 vuotta sitten
vanhempi
commit
0d103ba6b8

+ 1 - 0
meta-oe/conf/layer.conf

@@ -37,6 +37,7 @@ SIGGEN_EXCLUDERECIPES_ABISAFE += " \
   gpsd-machine-conf \
   distro-feed-configs \
   ca-certificates \
+  pointercal \
 "
 
 SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \

+ 2 - 0
meta-oe/recipes-bsp/pointercal/pointercal/COPYING

@@ -0,0 +1,2 @@
+This is a blank COPYING file, and should be filled in by original author in future.
+

+ 0 - 0
meta-oe/recipes-bsp/pointercal/pointercal/pointercal


+ 1 - 0
meta-oe/recipes-bsp/pointercal/pointercal/qemuarm/pointercal

@@ -0,0 +1 @@
+8313 4 -8526 7 8334 -82604 65536

+ 1 - 0
meta-oe/recipes-bsp/pointercal/pointercal/qemuarmv6/pointercal

@@ -0,0 +1 @@
+8313 4 -8526 7 8334 -82604 65536

+ 1 - 0
meta-oe/recipes-bsp/pointercal/pointercal/qemuarmv7/pointercal

@@ -0,0 +1 @@
+8313 4 -8526 7 8334 -82604 65536

+ 1 - 0
meta-oe/recipes-bsp/pointercal/pointercal/qemumips/pointercal

@@ -0,0 +1 @@
+8313 4 -8526 7 8334 -82604 65536

BIN
meta-oe/recipes-bsp/pointercal/pointercal/qemuppc/pointercal


+ 1 - 0
meta-oe/recipes-bsp/pointercal/pointercal/qemux86-64/pointercal

@@ -0,0 +1 @@
+1280 0 1002 0 960 328 65536

+ 1 - 0
meta-oe/recipes-bsp/pointercal/pointercal/qemux86/pointercal

@@ -0,0 +1 @@
+1280 0 1002 0 960 328 65536

+ 22 - 0
meta-oe/recipes-bsp/pointercal/pointercal_0.0.bb

@@ -0,0 +1,22 @@
+SUMMARY = "Touchscreen calibration data"
+SECTION = "base"
+PR = "r11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4b5fcfc87fb615860d398b5e38685edf"
+
+SRC_URI = "file://pointercal \
+           file://COPYING"
+
+S = "${WORKDIR}"
+
+do_install() {
+    # Only install file if it has a contents
+    if [ -s ${S}/pointercal ]; then
+        install -d ${D}${sysconfdir}/
+        install -m 0644 ${S}/pointercal ${D}${sysconfdir}/
+    fi
+}
+
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+INHIBIT_DEFAULT_DEPS = "1"