Procházet zdrojové kódy

ebtables: Add symbol link /sbin/ebtables

The original /sbin/ebtables has been moved to /usr/sbin/ebtables-legacy.
But the old path is still used by some other software libvirt.

libvirtd[809]: direct firewall backend requested,
but /sbin/ebtables is not available: No such file or directory

As stated in the related change in ebtable git repo:
The new -legacy binary has no problem if called via a symlink with the
'ebtables' name, so users can still name this binary with whatever name.

So we add a symbol link from /usr/sbin/ebtables-legacy to /sbin/ebtables.

Signed-off-by: He Zhe <zhe.he@windriver.com>
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
He Zhe před 3 roky
rodič
revize
00958a182e

+ 3 - 0
meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb

@@ -38,6 +38,9 @@ do_install_append () {
 		sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/ebtables.service
 		install -m 0755 ${WORKDIR}/ebtables.common ${D}${sbindir}/ebtables.common
 	fi
+
+	install -d ${D}${base_sbindir}
+	ln -sf ${sbindir}/ebtables-legacy ${D}${base_sbindir}/ebtables
 }
 
 do_configure_prepend () {