ebtables_2.0.11.bb 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. SUMMARY = "Filtering tool for a Linux-based bridging firewall"
  2. HOMEPAGE = "http://sourceforge.net/projects/ebtables/"
  3. DESCRIPTION = "Utility for basic Ethernet frame filtering on a Linux bridge, \
  4. advanced logging, MAC DNAT/SNAT and brouting."
  5. LICENSE = "GPLv2"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=53b4a999993871a28ab1488fdbd2e73e"
  7. SECTION = "net"
  8. RDEPENDS_${PN} += "bash perl"
  9. RRECOMMENDS_${PN} += "kernel-module-ebtables \
  10. "
  11. SRC_URI = "http://ftp.netfilter.org/pub/ebtables/ebtables-${PV}.tar.gz \
  12. file://0001-Makefile.am-do-not-install-etc-ethertypes.patch \
  13. file://ebtables-legacy-save \
  14. file://ebtables.common \
  15. file://ebtables.service \
  16. "
  17. SRC_URI_append_libc-musl = " file://0010-Adjust-header-include-sequence.patch"
  18. SRC_URI[md5sum] = "071c8b0a59241667a0044fb040d4fc72"
  19. SRC_URI[sha256sum] = "b71f654784a726329f88b412ef7b96b4e5d786ed2bd28193ed7b4c0d677dfd2a"
  20. inherit systemd autotools
  21. do_install_append () {
  22. # Replace upstream ebtables-save perl script with Fedora bash based rewrite
  23. # http://pkgs.fedoraproject.org/cgit/rpms/ebtables.git/tree/ebtables-save
  24. rm -f ${D}${sbindir}/ebtables-legacy-save
  25. install -m 0755 ${WORKDIR}/ebtables-legacy-save ${D}${sbindir}/ebtables-legacy-save
  26. # Install systemd service files
  27. if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
  28. install -d ${D}${systemd_unitdir}/system
  29. install -m 0644 ${WORKDIR}/ebtables.service ${D}${systemd_unitdir}/system
  30. sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/ebtables.service
  31. install -m 0755 ${WORKDIR}/ebtables.common ${D}${sbindir}/ebtables.common
  32. fi
  33. install -d ${D}${base_sbindir}
  34. ln -sf ${sbindir}/ebtables-legacy ${D}${base_sbindir}/ebtables
  35. }
  36. do_configure_prepend () {
  37. ( cd ${S}; ./autogen.sh )
  38. }
  39. FILES_${PN}-dbg += "${base_libdir}/ebtables/.debug"
  40. FILES_${PN} += "${base_libdir}/ebtables/*.so"
  41. SYSTEMD_SERVICE_${PN} = "ebtables.service"