Browse Source

fix cairo complie error
error:{
checking for cairo's cairo-trace feature...
checking whether cairo's cairo-trace feature could be enabled... no (requires dynamic linker and zlib and real pthreads)
configure: error: cairo-trace feature could not be enabled
}
reason:{
configure中对cairo_cc_stderr的check失败,加入调试信息具体错误信息如下:
warning: file /tmp/ccccki4R.o's arch flag ck810 conflict with target ck860,set target arch flag to ck860
}
solution:{
屏蔽configure中对phtread的编译check,并保存configure到meta-csky/recipes-graphics/cairo/cairo
}

tianshuliang 3 years ago
parent
commit
1145722059
2 changed files with 10943 additions and 14 deletions
  1. 10931 0
      recipes-graphics/cairo/cairo/configure
  2. 12 14
      recipes-graphics/cairo/cairo_1.16.0.bbappend

File diff suppressed because it is too large
+ 10931 - 0
recipes-graphics/cairo/cairo/configure


+ 12 - 14
recipes-graphics/cairo/cairo_1.16.0.bbappend

@@ -8,19 +8,17 @@ extended Porter/Duff compositing algebra as found in the X Render \
 Extension."
 
 
-do_configure () {
-	echo "Cairo->do_configure: Nothing to do !!"
-}
-
-do_compile () {
-	echo "Cairo->do_compile: Nothing to do !!"
-}
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
-do_install () {
-	echo "Cairo->do_install: Nothing to do !!"
+SRC_URI_append_csky = " \
+                      file://configure \
+                      "
+ 
+oe_runconf_prepend_csky() {
+        echo "THISDIR= ${THISDIR}/${PN}"
+        echo "PN=${PN}"
+        echo "PV=${PV}"
+        if [ -f "${WORKDIR}/configure" -a -d "${WORKDIR}/${PN}-${PV}" ]; then
+            cp -rf ${WORKDIR}/configure ${WORKDIR}/${PN}-${PV}/
+        fi
 }
-
-do_install_append () {
-	echo "Cairo->do_install_append: Nothing to do !!"
-}
-

Some files were not shown because too many files changed in this diff