cairo_1.16.0.bbappend 889 B

123456789101112131415161718192021222324
  1. SUMMARY = "The Cairo 2D vector graphics library"
  2. DESCRIPTION = "Cairo is a multi-platform library providing anti-aliased \
  3. vector-based rendering for multiple target backends. Paths consist \
  4. of line segments and cubic splines and can be rendered at any width \
  5. with various join and cap styles. All colors may be specified with \
  6. optional translucence (opacity/alpha) and combined using the \
  7. extended Porter/Duff compositing algebra as found in the X Render \
  8. Extension."
  9. FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
  10. SRC_URI_append_csky = " \
  11. file://configure \
  12. "
  13. oe_runconf_prepend_csky() {
  14. echo "THISDIR= ${THISDIR}/${PN}"
  15. echo "PN=${PN}"
  16. echo "PV=${PV}"
  17. if [ -f "${WORKDIR}/configure" -a -d "${WORKDIR}/${PN}-${PV}" ]; then
  18. cp -rf ${WORKDIR}/configure ${WORKDIR}/${PN}-${PV}/
  19. fi
  20. }