mnn_2.6.0.bb 699 B

1234567891011121314151617181920212223242526
  1. DESCRIPTION = "MNN is a blazing fast, lightweight deep learning framework, battle-tested by business-critical use cases in Alibaba"
  2. HOMEPAGE = "www.mnn.zone"
  3. LICENSE = "Apache-2.0"
  4. LIC_FILES_CHKSUM = "file://README.md;startline=124;endline=125;md5=49af4a1302656dc01a1c983ee77b8227"
  5. SRC_URI = " \
  6. git://github.com/alibaba/MNN.git;branch=master;protocol=https \
  7. file://run-ptest \
  8. "
  9. SRCREV = "c293f9eeab0a2983aa260ca81c751b09a389b16d"
  10. S = "${WORKDIR}/git"
  11. inherit cmake ptest
  12. EXTRA_OECMAKE = "-DMNN_BUILD_TEST=1"
  13. FILES:${PN} += "${libdir}/MNN*"
  14. SOLIBS = ".so"
  15. FILES_SOLIBSDEV = ""
  16. RDEPENDS:${PN} += "libstdc++"
  17. do_install_ptest() {
  18. install ${B}/run_test.out ${D}${PTEST_PATH}
  19. }