mnn_2.6.0.bb 746 B

12345678910111213141516171819202122232425262728
  1. DESCRIPTION = "MNN is a blazing fast, lightweight deep learning framework, battle-tested by business-critical use cases in Alibaba"
  2. HOMEPAGE = "www.mnn.zone"
  3. LICENSE = "Apache-2.0"
  4. LIC_FILES_CHKSUM = "file://README.md;startline=124;endline=125;md5=866c85dec0fa0932d17067810bf0e08c"
  5. SRC_URI = " \
  6. git://github.com/alibaba/MNN.git;branch=master;protocol=https \
  7. file://run-ptest \
  8. file://0001-fix-build-with-gcc-13.patch \
  9. "
  10. SRCREV = "d20f37fd7134127dde9201e74d38dc0c08d4a096"
  11. S = "${WORKDIR}/git"
  12. inherit cmake ptest
  13. EXTRA_OECMAKE = "-DMNN_BUILD_TEST=1"
  14. FILES:${PN} += "${libdir}/MNN*"
  15. SOLIBS = ".so"
  16. FILES_SOLIBSDEV = ""
  17. RDEPENDS:${PN} += "libstdc++"
  18. do_install_ptest() {
  19. install ${B}/run_test.out ${D}${PTEST_PATH}
  20. }