Преглед изворни кода

jpu-module: package JPU / CODAJ12 kernel module

Andreas Cord-Landwehr пре 1 година
родитељ
комит
94683d780e
2 измењених фајлова са 37 додато и 0 уклоњено
  1. 20 0
      recipes-kernel/modules/jpu-module.bb
  2. 17 0
      recipes-kernel/modules/jpu-module/Makefile

+ 20 - 0
recipes-kernel/modules/jpu-module.bb

@@ -0,0 +1,20 @@
+SUMMARY = "Kernel module for JPU"
+DESCRIPTION = "CODAJ12 performs JPEG encoding/decoding and is a chipset from Chip&Media"
+
+LICENSE = "ChipsMedia_VisionFive2"
+LIC_FILES_CHKSUM = "file://../../../LICENSE.txt;md5=16bead7cc56b053f5da0061ce0637ad2"
+
+COMPATIBLE_MACHINE = "visionfive2"
+
+JPU_MODULE_SRC = "git/codaj12/jdi/linux/driver"
+
+inherit module
+require recipes-bsp/common/visionfive2-firmware.inc
+
+SRC_URI += " \
+    file://Makefile;subdir=${JPU_MODULE_SRC} \
+"
+
+S = "${WORKDIR}/${JPU_MODULE_SRC}"
+
+RPROVIDES:${PN} += "kernel-module-jpu"

+ 17 - 0
recipes-kernel/modules/jpu-module/Makefile

@@ -0,0 +1,17 @@
+# SPDX-FileCopyrightText: 2023 Andreas Cord-Landwehr <cordlandwehr@kde.org>
+# SPDX-License-Identifier: MIT
+
+obj-m := jpu.o
+
+SRC := $(shell pwd)
+
+all:
+	$(MAKE) -C $(KERNEL_SRC) M=$(SRC)
+
+modules_install:
+	$(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+	rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
+	rm -f Module.markers Module.symvers modules.order
+	rm -rf .tmp_versions Modules.symvers