Browse Source

venc-module: add WAVE420l video encoder kernel module

Andreas Cord-Landwehr 1 year ago
parent
commit
b35f35d8dc
2 changed files with 39 additions and 0 deletions
  1. 22 0
      recipes-kernel/modules/venc-module.bb
  2. 17 0
      recipes-kernel/modules/venc-module/Makefile

+ 22 - 0
recipes-kernel/modules/venc-module.bb

@@ -0,0 +1,22 @@
+SUMMARY = "Kernel module for WAVE420l video encoder"
+DESCRIPTION = " WAVE420L is a low-cost HEVC/H.265 HW encoder IP from Chip&Media and is capable of \
+encoding FHD/UHD HEVC/H.265 main profile L4.1. WAVE420L was also call *VPU Enc*"
+
+LICENSE = "ChipsMedia_VisionFive2"
+LIC_FILES_CHKSUM = "file://../../../LICENSE.txt;md5=16bead7cc56b053f5da0061ce0637ad2"
+
+COMPATIBLE_MACHINE = "visionfive2"
+
+WAVE420L_MODULE_SRC = "git/wave420l/code/vdi/linux/driver"
+
+inherit module
+require recipes-bsp/common/visionfive2-firmware.inc
+
+SRC_URI += " \
+    file://Makefile;subdir=${WAVE420L_MODULE_SRC} \
+"
+
+S = "${WORKDIR}/${WAVE420L_MODULE_SRC}"
+
+RPROVIDES:${PN} += "kernel-module-venc"
+RDEPENDS:${PN} += "linux-firmware-visionfive2-wave420l"

+ 17 - 0
recipes-kernel/modules/venc-module/Makefile

@@ -0,0 +1,17 @@
+# SPDX-FileCopyrightText: 2023 Andreas Cord-Landwehr <cordlandwehr@kde.org>
+# SPDX-License-Identifier: MIT
+
+obj-m := venc.o
+
+SRC := $(shell pwd)
+
+all:
+	$(MAKE) -C $(KERNEL_SRC) M=$(SRC)
+
+modules_install:
+	$(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+	rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
+	rm -f Module.markers Module.symvers modules.order
+	rm -rf .tmp_versions Modules.symvers