Browse Source

dubhe: opensbi: Update opensbi version 1.1 to 1.2

Update opensbi version from 1.1 to 1.2.

Signed-off-by: yang.lee <yang.lee@starfivetech.com>
yang.lee 1 year ago
parent
commit
5fd7b0195c
2 changed files with 11 additions and 8 deletions
  1. 7 5
      recipes-bsp/opensbi/opensbi-payloads.inc
  2. 4 3
      recipes-bsp/opensbi/opensbi_1.2.bb

+ 7 - 5
recipes-bsp/opensbi/opensbi-payloads.inc

@@ -1,13 +1,15 @@
 def riscv_get_extra_oemake_image(d):
     sbi_payload = d.getVar('RISCV_SBI_PAYLOAD')
-    deploy_dir = d.getVar('DEPLOY_DIR_IMAGE')
-
     if sbi_payload is None:
         return ""
 
+    deploy_dir = d.getVar('DEPLOY_DIR_IMAGE')
+
     return "FW_PAYLOAD_PATH=" + deploy_dir + "/" + sbi_payload
 
 def riscv_get_extra_oemake_fdt(d):
+    if d.getVar('RISCV_SBI_PAYLOAD') is None:
+        return ""
     sbi_fdt = d.getVar('RISCV_SBI_FDT')
     deploy_dir = d.getVar('DEPLOY_DIR_IMAGE')
 
@@ -18,11 +20,11 @@ def riscv_get_extra_oemake_fdt(d):
 
 def riscv_get_do_compile_depends(d):
     sbi_payload = d.getVar('RISCV_SBI_PAYLOAD') or ""
-    sbi_fdt = d.getVar('RISCV_SBI_FDT') or ""
-
-    if sbi_payload == "" and sbi_fdt == "":
+    if sbi_payload == "":
         return ""
 
+    sbi_fdt = d.getVar('RISCV_SBI_FDT') or ""
+
     if sbi_fdt != "" and 'u-boot.bin' in sbi_payload:
         return "virtual/kernel:do_deploy virtual/bootloader:do_deploy"
 

+ 4 - 3
recipes-bsp/opensbi/opensbi_1.1.bb → recipes-bsp/opensbi/opensbi_1.2.bb

@@ -8,8 +8,8 @@ require opensbi-payloads.inc
 
 inherit autotools-brokensep deploy
 
-SRCREV = "bee8253d8f04c56017860386d1b2132cf4f4b7c5"
-SRC_URI = "git://git@github.com/starfive-tech/opensbi.git;protocol=https;branch=starfive-v1.1-dubhe"
+SRCREV = "df3de2f059c8c7edd1ba48ea43e6d8b93553a58a"
+SRC_URI = "git://git@192.168.110.45/starfive-tech/opensbi.git;protocol=ssh;branch=starfive-v1.2-dubhe"
 
 SRC_URI:remove:nezha = " \
     file://0001-lib-utils-fdt-Require-match-data-to-be-const.patch \
@@ -18,7 +18,8 @@ SRC_URI:remove:nezha = " \
 
 S = "${WORKDIR}/git"
 
-EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= "
+#EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= "
+EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} PLATFORM_DEFCONFIG=starfive_defconfig I=${D} FW_PIC=n CLANG_TARGET= "
 # If RISCV_SBI_PAYLOAD is set then include it as a payload
 EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_image(d)}"
 EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_fdt(d)}"