Browse Source

dubhe: busybox: Update config and boot script

This patch include fix for busybox CTRL+C.

Signed-off-by: yang.lee <yang.lee@starfivetech.com>
yang.lee 1 year ago
parent
commit
c4d6afbf8a

+ 2 - 0
recipes-core/busybox/busybox/fragment.cfg

@@ -0,0 +1,2 @@
+# Sun Dec 26 16:55:55 2021
+CONFIG_CTTYHACK=y

+ 2 - 0
recipes-core/busybox/busybox_%.bbappend

@@ -0,0 +1,2 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://fragment.cfg"

+ 14 - 0
recipes-core/initrdscripts/files/init-boot.sh

@@ -0,0 +1,14 @@
+#!/bin/sh
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+
+#sudo mkdir /proc
+#sudo mkdir /sys
+mount -t proc proc /proc
+mount -t sysfs sysfs /sys
+
+mknod -m 666 /dev/mem c 1 1
+
+mknod /dev/ttyS0 c 4 64
+mknod /dev/ttySIF0 c 249 0
+setsid cttyhack /bin/sh

+ 4 - 0
recipes-core/initrdscripts/initramfs-boot_1.0.bbappend

@@ -0,0 +1,4 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
+SRC_URI = "file://init-boot.sh"
+