Browse Source

dubhe: images: Remove obsolete image choices
Since U-Boot is up in Dubhe, all image variations (except UBIFS) can be merged into qspi-image.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 4 months ago
parent
commit
55bc15b8d2

+ 0 - 22
recipes-core/images/dubhe-image-essential.inc

@@ -1,22 +0,0 @@
-# Image Root Filesystem Configuration
-
-IMAGE_FSTYPES += "ext4 wic wic.gz wic.bmap"
-
-IMAGE_ROOTFS_SIZE ?= "8192"
-#IMAGE_ROOTFS_EXTRA_SPACE = "0"
-
-IMAGE_FEATURES += "allow-empty-password empty-root-password"
-IMAGE_FEATURES:remove = "dbg-pkgs"
-
-IMAGE_INSTALL += "\
-	packagegroup-starfive-essentials \
-	packagegroup-starfive-dubhe-essentials \
-	mtd-utils \
-	btrfs-tools \
-	parted \
-	lrzsz \
-	devmem2 \
-	e2fsprogs \
-	"
-
-TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"

+ 0 - 40
recipes-core/images/dubhe-image-minimal_0.1.bb

@@ -1,40 +0,0 @@
-SUMMARY = "Dubhe Image Minimal Creator"
-DESCRIPTION = "Recipe to create a Core Image"
-LICENSE = "CLOSED"
-
-inherit core-image
-
-DEPENDS += "opensbi deploy-bootfiles quilt quilt-native"
-
-LIC_FILES_CHKSUM = ""
-
-IMAGE_FSTYPES += "qspi_ext4 qspi_sd"
-
-require dubhe-image-essential.inc
-
-export IMAGE_BASENAME = "console-image-minimal"
-
-do_image_qspi_ext4[depends] += "\
-	deploy-bootfiles:do_deploy \
-	opensbi:do_deploy \
-	virtual/kernel:do_deploy \
-	"
-
-IMAGE_TYPEDEP:qspi_sd = "ext4 wic wic.gz wic.bmap"
-
-IMAGE_CMD:qspi_ext4 (){
-	dd if=${DEPLOY_DIR_IMAGE}/bootcode_min.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ext4-image.bin bs=32 seek=0 count=128
-        dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ext4-image.bin bs=32 seek=128 count=1
-        dd if=${DEPLOY_DIR_IMAGE}/dubhe90_fpga_ext4.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ext4-image.bin bs=32 seek=129 count=255
-        dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ext4-image.bin bs=32 seek=384
-
-	dd if=${DEPLOY_DIR_IMAGE}/bootcode_min.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ext4-image.bin bs=32 seek=0 count=128
-        dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ext4-image.bin bs=32 seek=128 count=1
-        dd if=${DEPLOY_DIR_IMAGE}/dubhe80_fpga_ext4.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ext4-image.bin bs=32 seek=129 count=255
-        dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ext4-image.bin bs=32 seek=384
-}
-
-IMAGE_CMD:qspi_sd (){
-	cd ${IMGDEPLOYDIR}
-	bmaptool copy console-image-minimal-starfive-dubhe.wic.gz ${DEPLOY_DIR_IMAGE}/SD-Image.img
-}

+ 0 - 17
recipes-core/images/qspi-nfs-essential.inc

@@ -1,17 +0,0 @@
-# Image Root Filesystem Configuration
-
-#IMAGE_FSTYPES += "ext4 wic wic.gz wic.bmap"
-
-IMAGE_ROOTFS_SIZE ?= "8192"
-#IMAGE_ROOTFS_EXTRA_SPACE = "0"
-
-IMAGE_FEATURES += "allow-empty-password empty-root-password"
-IMAGE_FEATURES:remove = "dbg-pkgs"
-
-IMAGE_INSTALL += "\
-	packagegroup-starfive-essentials \
-	packagegroup-starfive-dubhe-essentials \
-	mtd-utils \
-	"
-
-TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"

+ 0 - 43
recipes-core/images/qspi-nfs-image_0.1.bb

@@ -1,43 +0,0 @@
-SUMMARY = "Dubhe NFS Image Creator"
-DESCRIPTION = "Recipe to create a NFS Image"
-LICENSE = "CLOSED" 
-
-inherit core-image
-
-DEPENDS += "opensbi deploy-bootfiles quilt quilt-native"
-
-LIC_FILES_CHKSUM = ""
-
-IMAGE_FSTYPES += "qspi_nfs"
-
-require qspi-nfs-essential.inc
-
-export IMAGE_BASENAME = "nfs-rootfs"
-
-# NFS workaround
-#ROOTFS_POSTPROCESS_COMMAND += "nfs_rootfs ; lighttpd_rootfs ;"
-#nfs_rootfs(){
-#	cd ${IMAGE_ROOTFS}/lib/systemd/system/; sed -i '/Wants/a ConditionKernelCommandLine=!root=/dev/nfs' connman.service
-#}
-
-#lighttpd_rootfs(){
-#	rm ${IMAGE_ROOTFS}/var/log; mkdir -p ${IMAGE_ROOTFS}/var/log; touch ${IMAGE_ROOTFS}/var/log/lighttpd
-#}
-
-do_image_qspi_nfs[depends] += "\
-	deploy-bootfiles:do_deploy \
-	opensbi:do_deploy \
-	virtual/kernel:do_deploy \
-	"
-
-IMAGE_CMD:qspi_nfs (){
-	dd if=${DEPLOY_DIR_IMAGE}/bootcode_min.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-nfs-image.bin bs=32 seek=0 count=128
-        dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-nfs-image.bin bs=32 seek=128 count=1
-        dd if=${DEPLOY_DIR_IMAGE}/dubhe90_fpga_nfs.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-nfs-image.bin bs=32 seek=129 count=255
-        dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-nfs-image.bin bs=32 seek=384
-
-	dd if=${DEPLOY_DIR_IMAGE}/bootcode_min.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-nfs-image.bin bs=32 seek=0 count=128
-        dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-nfs-image.bin bs=32 seek=128 count=1
-        dd if=${DEPLOY_DIR_IMAGE}/dubhe80_fpga_nfs.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-nfs-image.bin bs=32 seek=129 count=255
-        dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-nfs-image.bin bs=32 seek=384
-}

+ 0 - 51
recipes-core/images/qspi-ubifs-image_0.1.bb

@@ -1,51 +0,0 @@
-SUMMARY = "QSPI Ubifs Image Creator"
-DESCRIPTION = "Recipe to create a QSPI Ubifs Image"
-LICENSE = "CLOSED"
-
-inherit core-image
-
-DEPENDS += "opensbi deploy-bootfiles quilt quilt-native"
-
-LIC_FILES_CHKSUM = ""
-
-IMAGE_FSTYPES = "ubi ubifs qspi_ubifs"
-MKUBIFS_ARGS = "-m 1 -e 65408 -c 26876"
-UBINIZE_ARGS = " -p 64KiB -m 1"
-
-IMAGE_ROOTFS_SIZE ?= "8192"
-
-IMAGE_FEATURES += "allow-empty-password empty-root-password"
-
-#IMAGE_INSTALL += "mtd-utils mtd-utils-ubifs kernel-modules"
-IMAGE_INSTALL += "\
-	packagegroup-starfive-essentials \
-	packagegroup-starfive-dubhe-essentials \
-	"
-
-TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"
-
-IMAGE_FEATURES:remove = "dbg-pkgs"
-
-export IMAGE_BASENAME = "qspi-ubifs"
-do_image_qspi_ubifs[depends] += "\
-	deploy-bootfiles:do_deploy \
-	opensbi:do_deploy \
-	virtual/kernel:do_deploy \
-	"
-
-IMAGE_TYPEDEP:qspi_ubifs = "ubi"
-
-IMAGE_CMD:qspi_ubifs () {
-        dd if=${DEPLOY_DIR_IMAGE}/bootcode.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=0 count=128
-        dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=128 count=1
-        dd if=${DEPLOY_DIR_IMAGE}/dubhe90_fpga_ubi.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=129 count=255
-        dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=384 count=1048192
-	dd if=${IMGDEPLOYDIR}/qspi-ubifs-starfive-dubhe.ubi of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=64KiB seek=512
-
-	dd if=${DEPLOY_DIR_IMAGE}/bootcode.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=32 seek=0 count=128
-        dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=32 seek=128 count=1
-        dd if=${DEPLOY_DIR_IMAGE}/dubhe80_fpga_ubi.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=32 seek=129 count=255
-        dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=32 seek=384 count=1048192
-        dd if=${IMGDEPLOYDIR}/qspi-ubifs-starfive-dubhe.ubi of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=64KiB seek=512
-}
-