dubhe-image-minimal_0.1.bb 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. SUMMARY = "Dubhe Image Minimal Creator"
  2. DESCRIPTION = "Recipe to create a Core Image"
  3. LICENSE = "CLOSED"
  4. inherit core-image
  5. DEPENDS += "opensbi deploy-bootfiles quilt quilt-native"
  6. LIC_FILES_CHKSUM = ""
  7. IMAGE_FSTYPES += "qspi_ext4 qspi_sd"
  8. require dubhe-image-essential.inc
  9. export IMAGE_BASENAME = "console-image-minimal"
  10. do_image_qspi_ext4[depends] += "\
  11. deploy-bootfiles:do_deploy \
  12. opensbi:do_deploy \
  13. virtual/kernel:do_deploy \
  14. "
  15. IMAGE_TYPEDEP:qspi_sd = "ext4 wic wic.gz wic.bmap"
  16. IMAGE_CMD:qspi_ext4 (){
  17. dd if=${DEPLOY_DIR_IMAGE}/bootcode_min.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ext4-image.bin bs=32 seek=0 count=128
  18. dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ext4-image.bin bs=32 seek=128 count=1
  19. dd if=${DEPLOY_DIR_IMAGE}/dubhe90_fpga_ext4.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ext4-image.bin bs=32 seek=129 count=255
  20. dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ext4-image.bin bs=32 seek=384
  21. dd if=${DEPLOY_DIR_IMAGE}/bootcode_min.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ext4-image.bin bs=32 seek=0 count=128
  22. dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ext4-image.bin bs=32 seek=128 count=1
  23. dd if=${DEPLOY_DIR_IMAGE}/dubhe80_fpga_ext4.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ext4-image.bin bs=32 seek=129 count=255
  24. dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ext4-image.bin bs=32 seek=384
  25. }
  26. IMAGE_CMD:qspi_sd (){
  27. cd ${IMGDEPLOYDIR}
  28. bmaptool copy console-image-minimal-starfive-dubhe.wic.gz ${DEPLOY_DIR_IMAGE}/SD-Image.img
  29. }