소스 검색

dubhe: linux-starfive-dev: Increase rsize & wsize in bootargs
This can reduce the number of NFS reconnection attempt for QSPI NFS image in a congested network condition.
Take note that the kernel message "nfs: server <nfs-server-ip> not responding, still trying" is will happen when user try to write a lot of data to the NFS.
However, the write operation will not stop, but the OS will be almost not responsive to user's terminal input if NFS rootfs is used.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 7 달 전
부모
커밋
484f6394ec
1개의 변경된 파일1개의 추가작업 그리고 1개의 파일을 삭제
  1. 1 1
      recipes-kernel/linux/linux-starfive-dev_6.1.20.bb

+ 1 - 1
recipes-kernel/linux/linux-starfive-dev_6.1.20.bb

@@ -44,7 +44,7 @@ FILES:${KERNEL_PACKAGE_NAME}-base += "/usr/*"
 
 BOOTARGS_EXT4 = "console=ttySIF0,115200 earlycon=sbi root=/dev/mmcblk0p2 rw rootfstype=ext4 rootwait ip=:::255.255.255.0::eth0:dhcp"
 BOOTARGS_UBI = "console=ttySIF0,115200 earlycon=sbi ip=:::255.255.255.0::eth0:dhcp root=ubi0:starfive-dubhe-rootfs ubi.mtd=1 rw rootfstype=ubifs rootwait"
-BOOTARGS_NFS = "console=ttySIF0,115200 earlycon=sbi root=/dev/nfs rw nfsroot=192.168.1.1:/filepath,rw,tcp,vers=3 ip=:::255.255.255.0::eth0:dhcp rootfstype=ext4 rootwait"
+BOOTARGS_NFS = "console=ttySIF0,115200 earlycon=sbi root=/dev/nfs rw nfsroot=192.168.1.1:/filepath,rw,tcp,vers=3,rsize=1048576,wsize=1048576 ip=:::255.255.255.0::eth0:dhcp rootfstype=ext4 rootwait"
 
 do_configure:append:starfive-dubhe() {
 	cp ${S}/arch/riscv/boot/dts/starfive/dubhe80_fpga.dts ${S}/arch/riscv/boot/dts/starfive/dubhe80_fpga_ext4.dts