Browse Source

openocd: Move openocd out of dynamic-layers

Move out from dynamic layers as it is essential for machines in
meta-starfive.

Signed-off-by: Jun Yuan Tan <junyuan.tan@starfivetech.com>
Jun Yuan Tan 6 months ago
parent
commit
3616386f24

+ 0 - 0
dynamic-layers/openembedded-layer/recipes-devtools/openocd/openocd/0001-autosetup-cc-check-tools-check-only-the-name.patch → recipes-devtools/openocd/openocd/0001-autosetup-cc-check-tools-check-only-the-name.patch


+ 0 - 0
dynamic-layers/openembedded-layer/recipes-devtools/openocd/openocd/Dubhe_FPGA_openocd.patch → recipes-devtools/openocd/openocd/Dubhe_FPGA_openocd.patch


+ 0 - 0
dynamic-layers/openembedded-layer/recipes-devtools/openocd/openocd/dubhe_olimex-openocd_s5.cfg → recipes-devtools/openocd/openocd/dubhe_olimex-openocd_s5.cfg


+ 0 - 0
dynamic-layers/openembedded-layer/recipes-devtools/openocd/openocd/dubhe_olimex_flash_write.cfg → recipes-devtools/openocd/openocd/dubhe_olimex_flash_write.cfg


+ 0 - 0
dynamic-layers/openembedded-layer/recipes-devtools/openocd/openocd/jh8100_0150_f1.cfg → recipes-devtools/openocd/openocd/jh8100_0150_f1.cfg


+ 0 - 0
dynamic-layers/openembedded-layer/recipes-devtools/openocd/openocd/jh8100_0150_f2.cfg → recipes-devtools/openocd/openocd/jh8100_0150_f2.cfg


+ 0 - 0
dynamic-layers/openembedded-layer/recipes-devtools/openocd/openocd/jh8100_jrc.cfg → recipes-devtools/openocd/openocd/jh8100_jrc.cfg


+ 16 - 0
recipes-devtools/openocd/openocd_riscv.bb

@@ -0,0 +1,16 @@
+require recipes-devtools/openocd/openocd_git.bb
+
+PV = "riscv"
+
+SRC_URI = " \
+    git://github.com/riscv/riscv-openocd.git;protocol=https;branch=riscv;name=openocd \
+    git://repo.or.cz/r/git2cl.git;protocol=http;branch=master;destsuffix=tools/git2cl;name=git2cl \
+    git://repo.or.cz/r/jimtcl.git;protocol=http;branch=master;destsuffix=git/jimtcl;name=jimtcl \
+    git://repo.or.cz/r/libjaylink.git;protocol=http;branch=master;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \
+"
+
+SRCREV_openocd = "50a5971be27ff11061776afc8014bbff22870b7c"
+
+EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html --disable-werror --enable-jtag_vpi"
+
+COMPATIBLE_HOST = "(x86_64.*|i.86.*|riscv32|riscv64).*-linux"

+ 6 - 2
dynamic-layers/openembedded-layer/recipes-devtools/openocd/openocd_riscv.bbappend → recipes-devtools/openocd/openocd_riscv.bbappend

@@ -1,8 +1,10 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/openocd:"
+require recipes-devtools/openocd/openocd_git.bb
+
+#FILESEXTRAPATHS:prepend := "${THISDIR}/openocd:"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=599d2d1ee7fc84c0467b3d19801db870"
 
-PV = "riscv22"
+PV = "riscv"
 
 SRC_URI = " \
     git://github.com/riscv/riscv-openocd.git;protocol=https;branch=riscv;name=openocd \
@@ -34,3 +36,5 @@ do_deploy() {
 }
 
 addtask deploy before do_build after do_install
+
+COMPATIBLE_HOST = "(x86_64.*|i.86.*|riscv32|riscv64).*-linux"