Browse Source

dhrystone: Remove recipe
meta-openembedded has its own dhrystone recipe that can be leveraged.
Change to meta-starfive's specific CFLAGS in bbappend file.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 5 months ago
parent
commit
3ed4ee1708

+ 0 - 21
recipes-benchmark/dhrystone/dhrystone/dhrystone-edit-compiler-flags.patch

@@ -1,21 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 6fb3e5a..6fe5fd4 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,10 +1,13 @@
- DHRY-LFLAGS =
- 
--DHRY-CFLAGS := -O3 -DTIME -DNOENUM -Wno-implicit -save-temps
--DHRY-CFLAGS += -fno-builtin-printf -fno-common -falign-functions=4
-+# Best effort
-+DHRY-CFLAGS := -O2 -DTIME -Wno-implicit -fno-builtin-printf -fno-common -static -mcmodel=medany -ffast-math -fno-common -falign-jumps=8 -falign-loops=8 -falign-functions=8
-+
-+# Legal
-+#DHRY-CFLAGS := -O2 -DTIME -Wno-implicit -fno-builtin-printf -fno-common -static -mcmodel=medany -ffast-math -fno-common -falign-jumps=8 -falign-loops=8 -falign-functions=8 -fno-inline
- 
- #Uncomment below for FPGA run, default DHRY_ITERS is 2000 for RTL
--#DHRY-CFLAGS += -DDHRY_ITERS=20000000
-+DHRY-CFLAGS += -DDHRY_ITERS=20000000
- 
- SRC = dhry_1.c dhry_2.c strcmp.S
- HDR = dhry.h

+ 0 - 26
recipes-benchmark/dhrystone/dhrystone_2.1.bb

@@ -1,26 +0,0 @@
-SUMMARY = "Dhrystone CPU benchmark"
-LICENSE = "PD"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851"
-
-INHIBIT_PACKAGE_STRIP = "1"
-
-BRANCH = "master"
-SRC_URI = "git://github.com/sifive/benchmark-dhrystone.git;protocol=ssh;branch=${BRANCH} \
-           file://dhrystone-edit-compiler-flags.patch \
-           "
-SRCREV = "0ddff533cc9052c524990d5ace4560372053314b"
-
-S = "${WORKDIR}/git"
-
-TARGET_CC_ARCH += "${LDFLAGS}"
-EXTRA_OEMAKE += "'CC=${CC}'"
-
-do_compile(){
-	oe_runmake dhrystone
-}
-
-do_install() {
-    install -d ${D}${bindir}
-    install -m 0755 dhrystone ${D}${bindir}
-}
-

+ 5 - 0
recipes-benchmark/dhrystone/dhrystone_2.1.bbappend

@@ -0,0 +1,5 @@
+# Best effort
+CFLAGS = "-O2 -DTIME -Wno-implicit -fno-builtin-printf -fno-common -static -mcmodel=medany -ffast-math -fno-common -falign-jumps=8 -falign-loops=8 -falign-functions=8"
+
+# Legal
+#CFLAGS = "-O2 -DTIME -Wno-implicit -fno-builtin-printf -fno-common -static -mcmodel=medany -ffast-math -fno-common -falign-jumps=8 -falign-loops=8 -falign-functions=8 -fno-inline"