Browse Source

core-image-starfive-extra: Add new image for StarFive

This is an image with additional default packages for StarFive.

Signed-off-by: Jun Yuan Tan <junyuan.tan@starfivetech.com>
Jun Yuan Tan 8 months ago
parent
commit
2696ecc28d
2 changed files with 45 additions and 0 deletions
  1. 39 0
      recipes-core/images/core-image-starfive-extra.bb
  2. 6 0
      recipes-core/images/sd-image.inc

+ 39 - 0
recipes-core/images/core-image-starfive-extra.bb

@@ -0,0 +1,39 @@
+SUMMARY = "A StarFive image with additional packages."
+
+require sd-image.inc
+
+DEPENDS += " opensbi u-boot-tools-native dtc-native"
+
+IMAGE_INSTALL = "packagegroup-core-boot \
+		${CORE_IMAGE_EXTRA_INSTALL} \
+		helloworld \
+        	coremark \
+        	dhrystone \
+        	perf \
+        	gdb \
+        	gdbserver \
+        	util-linux \
+        	ethtool \
+        	bmap-tools \
+        	systemd-analyze \
+        	openssh \
+        	e2fsprogs-resize2fs \
+		ldd \
+		file \
+		git \
+		texinfo \
+		libcheck \
+		packagegroup-core-buildessential \
+		packagegroup-starfive-c \
+		nodejs \
+        	nodejs-npm \
+		"
+
+IMAGE_LINGUAS = " "
+
+LICENSE = "MIT"
+
+inherit core-image
+
+IMAGE_ROOTFS_SIZE ?= "8192"
+IMAGE_ROOTFS_EXTRA_SPACE:append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "", d)}"

+ 6 - 0
recipes-core/images/sd-image.inc

@@ -9,4 +9,10 @@ do_vf2_sd (){
         spl_tool -i -f ${DEPLOY_DIR_IMAGE}/${MACHINE}-${PN}.img
 }
 
+do_jh8100_fpga_image (){
+        cd ${IMGDEPLOYDIR}
+        bmaptool copy ${PN}-${MACHINE}.wic.gz ${DEPLOY_DIR_IMAGE}/${MACHINE}-${PN}.img
+}
+
 IMAGE_POSTPROCESS_COMMAND:starfive-visionfive2 += "do_vf2_sd;"
+IMAGE_POSTPROCESS_COMMAND:starfive-jh8100 += "do_jh8100_fpga_image;"