core-image-starfive-extra.bb 799 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. SUMMARY = "A StarFive image with additional packages."
  2. require sd-image.inc
  3. DEPENDS += " opensbi u-boot-tools-native dtc-native"
  4. IMAGE_INSTALL = "packagegroup-core-boot \
  5. ${CORE_IMAGE_EXTRA_INSTALL} \
  6. helloworld \
  7. coremark \
  8. dhrystone \
  9. perf \
  10. gdb \
  11. gdbserver \
  12. util-linux \
  13. ethtool \
  14. bmap-tools \
  15. systemd-analyze \
  16. openssh \
  17. e2fsprogs-resize2fs \
  18. ldd \
  19. file \
  20. git \
  21. texinfo \
  22. libcheck \
  23. packagegroup-core-buildessential \
  24. packagegroup-starfive-c \
  25. nodejs \
  26. nodejs-npm \
  27. "
  28. IMAGE_LINGUAS = " "
  29. LICENSE = "MIT"
  30. inherit core-image
  31. IMAGE_ROOTFS_SIZE ?= "8192"
  32. IMAGE_ROOTFS_EXTRA_SPACE:append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "", d)}"