git.mk 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. ################################################################################
  2. #
  3. # git
  4. #
  5. ################################################################################
  6. GIT_VERSION = 1.8.5.4
  7. GIT_SITE = http://git-core.googlecode.com/files
  8. GIT_LICENSE = GPLv2 LGPLv2.1+
  9. GIT_LICENSE_FILES = COPYING LGPL-2.1
  10. GIT_DEPENDENCIES = zlib host-gettext
  11. ifeq ($(BR2_PACKAGE_OPENSSL),y)
  12. GIT_DEPENDENCIES += openssl
  13. GIT_CONF_OPT += --with-openssl
  14. else
  15. GIT_CONF_OPT += --without-openssl
  16. endif
  17. ifeq ($(BR2_PACKAGE_PERL),y)
  18. GIT_DEPENDENCIES += perl
  19. GIT_CONF_OPT += --with-libpcre
  20. else
  21. GIT_CONF_OPT += --without-libpcre
  22. endif
  23. ifeq ($(BR2_PACKAGE_CURL),y)
  24. GIT_DEPENDENCIES += curl
  25. GIT_CONF_OPT += --with-curl
  26. else
  27. GIT_CONF_OPT += --without-curl
  28. endif
  29. ifeq ($(BR2_PACKAGE_EXPAT),y)
  30. GIT_DEPENDENCIES += expat
  31. GIT_CONF_OPT += --with-expat
  32. else
  33. GIT_CONF_OPT += --without-expat
  34. endif
  35. ifeq ($(BR2_PACKAGE_LIBICONV),y)
  36. GIT_DEPENDENCIES += libiconv
  37. GIT_CONF_ENV += LIBS=-liconv
  38. GIT_CONF_OPT += --with-iconv=/usr/lib
  39. else
  40. GIT_CONF_OPT += --without-iconv
  41. endif
  42. ifeq ($(BR2_PACKAGE_TCL),y)
  43. GIT_DEPENDENCIES += tcl
  44. GIT_CONF_OPT += --with-tcltk
  45. else
  46. GIT_CONF_OPT += --without-tcltk
  47. endif
  48. # assume yes for these tests, configure will bail out otherwise
  49. # saying error: cannot run test program while cross compiling
  50. GIT_CONF_ENV += ac_cv_fread_reads_directories=yes \
  51. ac_cv_snprintf_returns_bogus=yes
  52. $(eval $(autotools-package))