dcron.mk 1.3 KB

123456789101112131415161718192021222324252627282930313233343536
  1. ################################################################################
  2. #
  3. # dcron
  4. #
  5. ################################################################################
  6. DCRON_VERSION = 4.5
  7. DCRON_SITE = http://www.jimpryor.net/linux/releases
  8. # The source code does not specify the version of the GPL that is used.
  9. DCRON_LICENSE = GPL
  10. # Overwrite cron-related Busybox commands if available
  11. ifeq ($(BR2_PACKAGE_BUSYBOX),y)
  12. DCRON_DEPENDENCIES = busybox
  13. endif
  14. define DCRON_BUILD_CMDS
  15. $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
  16. endef
  17. define DCRON_INSTALL_TARGET_CMDS
  18. $(INSTALL) -D -m0700 $(@D)/crond $(TARGET_DIR)/usr/sbin/crond
  19. $(INSTALL) -D -m4755 $(@D)/crontab $(TARGET_DIR)/usr/bin/crontab
  20. $(INSTALL) -D -m0644 $(@D)/extra/root.crontab $(TARGET_DIR)/etc/cron.d/system
  21. # Busybox provides run-parts, so there is no need to use nor install provided run-cron
  22. $(SED) 's#/usr/sbin/run-cron#/bin/run-parts#g' $(TARGET_DIR)/etc/cron.d/system
  23. $(INSTALL) -d -m0755 $(TARGET_DIR)/var/spool/cron/crontabs \
  24. $(TARGET_DIR)/etc/cron.daily $(TARGET_DIR)/etc/cron.hourly \
  25. $(TARGET_DIR)/etc/cron.monthly $(TARGET_DIR)/etc/cron.weekly
  26. endef
  27. define DCRON_INSTALL_INIT_SYSV
  28. $(INSTALL) -D -m 0755 package/dcron/S90dcron $(TARGET_DIR)/etc/init.d/S90dcron
  29. endef
  30. $(eval $(generic-package))