chrony.mk 999 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. ################################################################################
  2. #
  3. # chrony
  4. #
  5. ################################################################################
  6. CHRONY_VERSION = 1.29.1
  7. CHRONY_SITE = http://download.tuxfamily.org/chrony
  8. CHRONY_LICENSE = GPLv2
  9. CHRONY_LICENSE_FILES = COPYING
  10. CHRONY_CONF_OPT = --host-system=Linux --host-machine=$(BR2_ARCH) --prefix=/usr
  11. ifeq ($(BR2_PACKAGE_LIBNSS),y)
  12. CHRONY_DEPENDENCIES += host-pkgconf libnss
  13. else
  14. CHRONY_CONF_OPT += --without-nss
  15. endif
  16. ifeq ($(BR2_PACKAGE_READLINE),y)
  17. CHRONY_DEPENDENCIES += readline
  18. else
  19. CHRONY_CONF_OPT += --disable-readline
  20. endif
  21. ifneq ($(BR2_INET_IPV6),y)
  22. CHRONY_CONF_OPT += --disable-ipv6
  23. endif
  24. define CHRONY_CONFIGURE_CMDS
  25. cd $(@D) && $(TARGET_CONFIGURE_OPTS) ./configure $(CHRONY_CONF_OPT)
  26. endef
  27. define CHRONY_BUILD_CMDS
  28. $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
  29. endef
  30. define CHRONY_INSTALL_TARGET_CMDS
  31. $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR="$(TARGET_DIR)" install
  32. endef
  33. $(eval $(generic-package))