atk.mk 2.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. ################################################################################
  2. #
  3. # atk
  4. #
  5. ################################################################################
  6. ATK_VERSION_MAJOR = 2.10
  7. ATK_VERSION = $(ATK_VERSION_MAJOR).0
  8. ATK_SOURCE = atk-$(ATK_VERSION).tar.xz
  9. ATK_SITE = http://ftp.gnome.org/pub/gnome/sources/atk/$(ATK_VERSION_MAJOR)
  10. ATK_LICENSE = LGPLv2+
  11. ATK_LICENSE_FILES = COPYING
  12. ATK_INSTALL_STAGING = YES
  13. ATK_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) LDFLAGS=-L$(STAGING_DIR)/usr/lib install
  14. ATK_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes \
  15. glib_cv_stack_grows=no glib_cv_uscore=no \
  16. ac_cv_func_strtod=yes ac_fsusage_space=yes \
  17. fu_cv_sys_stat_statfs2_bsize=yes ac_cv_func_closedir_void=no \
  18. ac_cv_func_getloadavg=no ac_cv_lib_util_getloadavg=no \
  19. ac_cv_lib_getloadavg_getloadavg=no ac_cv_func_getgroups=yes \
  20. ac_cv_func_getgroups_works=yes ac_cv_func_chown_works=yes \
  21. ac_cv_have_decl_euidaccess=no ac_cv_func_euidaccess=no \
  22. ac_cv_have_decl_strnlen=yes ac_cv_func_strnlen_working=yes \
  23. ac_cv_func_lstat_dereferences_slashed_symlink=yes ac_cv_func_lstat_empty_string_bug=no \
  24. ac_cv_func_stat_empty_string_bug=no vb_cv_func_rename_trailing_slash_bug=no \
  25. ac_cv_have_decl_nanosleep=yes jm_cv_func_nanosleep_works=yes \
  26. gl_cv_func_working_utimes=yes ac_cv_func_utime_null=yes \
  27. ac_cv_have_decl_strerror_r=yes ac_cv_func_strerror_r_char_p=no \
  28. jm_cv_func_svid_putenv=yes ac_cv_func_getcwd_null=yes \
  29. ac_cv_func_getdelim=yes ac_cv_func_mkstemp=yes \
  30. utils_cv_func_mkstemp_limitations=no utils_cv_func_mkdir_trailing_slash_bug=no \
  31. ac_cv_func_memcmp_working=yes ac_cv_have_decl_malloc=yes \
  32. jm_cv_func_gettimeofday_clobber=no gl_cv_func_working_readdir=yes \
  33. jm_ac_cv_func_link_follows_symlink=no utils_cv_localtime_cache=no \
  34. ac_cv_struct_st_mtim_nsec=no gl_cv_func_tzset_clobber=no \
  35. gl_cv_func_getcwd_null=yes gl_cv_func_getcwd_path_max=yes \
  36. ac_cv_func_fnmatch_gnu=yes am_getline_needs_run_time_check=no \
  37. am_cv_func_working_getline=yes gl_cv_func_mkdir_trailing_slash_bug=no \
  38. gl_cv_func_mkstemp_limitations=no ac_cv_func_working_mktime=yes \
  39. jm_cv_func_working_re_compile_pattern=yes ac_use_included_regex=no \
  40. gl_cv_c_restrict=no ac_cv_prog_F77=no
  41. ATK_CONF_OPT = --disable-glibtest --enable-explicit-deps=no \
  42. --disable-debug
  43. ATK_DEPENDENCIES = libglib2 host-pkgconf
  44. $(eval $(autotools-package))