aiccu.mk 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. ################################################################################
  2. #
  3. # aiccu
  4. #
  5. ################################################################################
  6. AICCU_VERSION = 20070115
  7. AICCU_SOURCE = aiccu_$(AICCU_VERSION).tar.gz
  8. AICCU_SITE = http://www.sixxs.net/archive/sixxs/aiccu/unix
  9. AICCU_LICENSE = SixXS License, concise redistribution license
  10. AICCU_LICENSE_FILES = doc/LICENSE
  11. AICCU_DEPENDENCIES = gnutls
  12. AICCU_LFDLAGS = $(TARGET_LDFLAGS)
  13. # aiccu forgets to link with gnutls' dependencies breaking the build when
  14. # linking statically
  15. ifeq ($(BR2_PREFER_STATIC_LIB),y)
  16. AICCU_LDFLAGS += $(shell $(PKG_CONFIG_HOST_BINARY) --static --libs gnutls)
  17. endif
  18. # dummy RPM_OPT_FLAGS to disable stripping
  19. define AICCU_BUILD_CMDS
  20. $(TARGET_CONFIGURE_OPTS) LDFLAGS="$(AICCU_LDFLAGS)" $(MAKE) \
  21. CC="$(TARGET_CC)" RPM_OPT_FLAGS=1 -C $(@D)/unix-console all
  22. endef
  23. define AICCU_INSTALL_TARGET_CMDS
  24. $(INSTALL) -D -m 0755 $(@D)/unix-console/aiccu \
  25. $(TARGET_DIR)/usr/sbin/aiccu
  26. [ -f $(TARGET_DIR)/etc/aiccu.conf ] || \
  27. $(INSTALL) -D -m 0644 $(@D)/doc/aiccu.conf \
  28. $(TARGET_DIR)/etc/aiccu.conf
  29. endef
  30. define AICCU_INSTALL_INIT_SYSV
  31. [ -f $(TARGET_DIR)/etc/init.d/S50aiccu ] || \
  32. $(INSTALL) -D -m 0755 $(@D)/doc/aiccu.init \
  33. $(TARGET_DIR)/etc/init.d/S50aiccu
  34. endef
  35. $(eval $(generic-package))