libupnpp.mk 725 B

12345678910111213141516171819202122
  1. ################################################################################
  2. #
  3. # libupnpp
  4. #
  5. ################################################################################
  6. LIBUPNPP_VERSION = 0.16.0
  7. LIBUPNPP_SITE = http://www.lesbonscomptes.com/upmpdcli/downloads
  8. LIBUPNPP_LICENSE = GPL-2.0+
  9. LIBUPNPP_LICENSE_FILES = COPYING
  10. LIBUPNPP_INSTALL_STAGING = YES
  11. LIBUPNPP_DEPENDENCIES = expat libcurl libupnp
  12. # configure script fails to link against the dependencies of libupnp
  13. # and libcurl causing detection to fail when statically linking
  14. ifeq ($(BR2_STATIC_LIBS),y)
  15. LIBUPNPP_DEPENDENCIES += host-pkgconf
  16. LIBUPNPP_CONF_ENV += \
  17. LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs libupnp libcurl`"
  18. endif
  19. $(eval $(autotools-package))