sdl.mk 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899
  1. ################################################################################
  2. #
  3. # sdl
  4. #
  5. ################################################################################
  6. #SDL_VERSION = 1.2.15
  7. #SDL_SOURCE = SDL-$(SDL_VERSION).tar.gz
  8. #SDL_SITE = http://www.libsdl.org/release
  9. SDL_VERSION = 1d23399e67582c503e53424c86247fc8f39339a5
  10. SDL_SITE_METHOD = git
  11. SDL_SITE = https://github.com/FunKey-Project/SDL-1.2.git
  12. SDL_LICENSE = LGPL-2.1+
  13. SDL_LICENSE_FILES = COPYING
  14. SDL_INSTALL_STAGING = YES
  15. # we're patching configure.in, but package cannot autoreconf with our version of
  16. # autotools, so we have to do it manually instead of setting SDL_AUTORECONF = YES
  17. define SDL_RUN_AUTOGEN
  18. cd $(@D) && PATH=$(BR_PATH) ./autogen.sh
  19. endef
  20. SDL_PRE_CONFIGURE_HOOKS += SDL_RUN_AUTOGEN
  21. HOST_SDL_PRE_CONFIGURE_HOOKS += SDL_RUN_AUTOGEN
  22. SDL_DEPENDENCIES += host-automake host-autoconf host-libtool
  23. HOST_SDL_DEPENDENCIES += host-automake host-autoconf host-libtool
  24. SDL_CONF_OPTS += --enable-video-qtopia=no
  25. ifeq ($(BR2_PACKAGE_SDL_FBCON),y)
  26. SDL_CONF_OPTS += --enable-video-fbcon=yes
  27. else
  28. SDL_CONF_OPTS += --enable-video-fbcon=no
  29. endif
  30. ifeq ($(BR2_PACKAGE_SDL_DIRECTFB),y)
  31. SDL_DEPENDENCIES += directfb
  32. SDL_CONF_OPTS += --enable-video-directfb=yes
  33. SDL_CONF_ENV = ac_cv_path_DIRECTFBCONFIG=$(STAGING_DIR)/usr/bin/directfb-config
  34. else
  35. SDL_CONF_OPTS += --enable-video-directfb=no
  36. endif
  37. ifeq ($(BR2_PACKAGE_SDL_X11),y)
  38. SDL_CONF_OPTS += --enable-video-x11=yes
  39. SDL_DEPENDENCIES += \
  40. xlib_libX11 xlib_libXext \
  41. $(if $(BR2_PACKAGE_XLIB_LIBXRENDER), xlib_libXrender) \
  42. $(if $(BR2_PACKAGE_XLIB_LIBXRANDR), xlib_libXrandr)
  43. else
  44. SDL_CONF_OPTS += --enable-video-x11=no
  45. endif
  46. ifneq ($(BR2_USE_MMU),y)
  47. SDL_CONF_OPTS += --enable-dga=no
  48. endif
  49. # overwrite autodection (prevents confusion with host libpth version)
  50. ifeq ($(BR2_PACKAGE_LIBPTHSEM_COMPAT),y)
  51. SDL_CONF_OPTS += --enable-pth
  52. SDL_CONF_ENV += ac_cv_path_PTH_CONFIG=$(STAGING_DIR)/usr/bin/pth-config
  53. SDL_DEPENDENCIES += libpthsem
  54. else
  55. SDL_CONF_OPTS += --disable-pth
  56. endif
  57. ifeq ($(BR2_PACKAGE_TSLIB),y)
  58. SDL_DEPENDENCIES += tslib
  59. endif
  60. ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
  61. SDL_DEPENDENCIES += alsa-lib
  62. endif
  63. ifeq ($(BR2_PACKAGE_MESA3D),y)
  64. SDL_DEPENDENCIES += mesa3d
  65. endif
  66. SDL_CONF_OPTS += \
  67. --disable-rpath \
  68. --enable-pulseaudio=no \
  69. --disable-arts \
  70. --disable-esd \
  71. --disable-nasm \
  72. --disable-video-ps3
  73. HOST_SDL_CONF_OPTS += \
  74. --enable-pulseaudio=no \
  75. --enable-video-x11=no \
  76. --disable-arts \
  77. --disable-esd \
  78. --disable-nasm \
  79. --disable-video-ps3
  80. SDL_CONFIG_SCRIPTS = sdl-config
  81. $(eval $(autotools-package))
  82. $(eval $(host-autotools-package))