bandwidthd.mk 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. ################################################################################
  2. #
  3. # bandwidthd
  4. #
  5. ################################################################################
  6. BANDWIDTHD_VERSION = 2.0.1-auto-r11
  7. BANDWIDTHD_SITE = $(call github,nroach44,bandwidthd,v$(BANDWIDTHD_VERSION))
  8. # Specified as "any version of the GPL that is current as of your
  9. # download" by upstream.
  10. BANDWIDTHD_LICENSE = GPL
  11. BANDWIDTHD_LICENSE_FILES = README
  12. BANDWIDTHD_DEPENDENCIES = gd libpng libpcap host-pkgconf
  13. BANDWIDTHD_AUTORECONF = YES
  14. BANDWIDTHD_CONF_OPTS += --with-pcap-config=$(STAGING_DIR)/usr/bin/pcap-config
  15. ifeq ($(BR2_PACKAGE_BANDWIDTHD_POSTGRESQL),y)
  16. BANDWIDTHD_DEPENDENCIES += postgresql
  17. BANDWIDTHD_CONF_OPTS += --with-postgresql-logging=true
  18. else
  19. BANDWIDTHD_CONF_OPTS += --with-postgresql-logging=false
  20. endif
  21. ifeq ($(BR2_PACKAGE_BANDWIDTHD_SQLITE3),y)
  22. BANDWIDTHD_DEPENDENCIES += sqlite
  23. BANDWIDTHD_CONF_OPTS += --with-sqlite-storage=true
  24. else
  25. BANDWIDTHD_CONF_OPTS += --with-sqlite-storage=false
  26. endif
  27. define BANDWIDTHD_INSTALL_INIT_SYSTEMD
  28. $(INSTALL) -D -m 644 package/bandwidthd/bandwidthd.service \
  29. $(TARGET_DIR)/usr/lib/systemd/system/bandwidthd.service
  30. endef
  31. $(eval $(autotools-package))