librelp.mk 705 B

123456789101112131415161718192021222324252627
  1. ################################################################################
  2. #
  3. # librelp
  4. #
  5. ################################################################################
  6. LIBRELP_VERSION = 1.8.0
  7. LIBRELP_SITE = http://download.rsyslog.com/librelp
  8. LIBRELP_LICENSE = GPL-3.0+
  9. LIBRELP_LICENSE_FILES = COPYING
  10. LIBRELP_INSTALL_STAGING = YES
  11. ifeq ($(BR2_PACKAGE_GNUTLS),y)
  12. LIBRELP_DEPENDENCIES += gnutls host-pkgconf
  13. LIBRELP_CONF_OPTS += --enable-tls
  14. else
  15. LIBRELP_CONF_OPTS += --disable-tls
  16. endif
  17. ifeq ($(BR2_PACKAGE_HAS_OPENSSL),y)
  18. LIBRELP_DEPENDENCIES += openssl host-pkgconf
  19. LIBRELP_CONF_OPTS += --enable-tls-openssl
  20. else
  21. LIBRELP_CONF_OPTS += --disable-tls-openssl
  22. endif
  23. $(eval $(autotools-package))