doom-wad.mk 797 B

123456789101112131415161718192021222324
  1. ################################################################################
  2. #
  3. # doom-wad
  4. #
  5. ################################################################################
  6. DOOM_WAD_VERSION = 1.9
  7. DOOM_WAD_SOURCE = doom$(subst .,,$(DOOM_WAD_VERSION))s.zip
  8. # Official server currently unavailable
  9. # DOOM_WAD_SITE = ftp://ftp.idsoftware.com/idstuff/doom
  10. DOOM_WAD_SITE = http://www.jbserver.com/downloads/games/doom/misc/shareware
  11. define DOOM_WAD_EXTRACT_CMDS
  12. $(UNZIP) -p $(DOOM_WAD_DL_DIR)/$($(PKG)_SOURCE) 'DOOMS_19.[12]' > \
  13. $(@D)/doom-$(DOOM_WAD_VERSION).zip
  14. $(UNZIP) -d $(@D) $(@D)/doom-$(DOOM_WAD_VERSION).zip DOOM1.WAD
  15. endef
  16. define DOOM_WAD_INSTALL_TARGET_CMDS
  17. $(INSTALL) -m 0644 -D $(@D)/DOOM1.WAD \
  18. $(TARGET_DIR)/usr/share/games/doom/doom1.wad
  19. endef
  20. $(eval $(generic-package))