unbound.mk 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. ################################################################################
  2. #
  3. # unbound
  4. #
  5. ################################################################################
  6. UNBOUND_VERSION = 1.13.0
  7. UNBOUND_SITE = https://www.unbound.net/downloads
  8. UNBOUND_DEPENDENCIES = host-pkgconf expat libevent openssl
  9. UNBOUND_LICENSE = BSD-3-Clause
  10. UNBOUND_LICENSE_FILES = LICENSE
  11. UNBOUND_CONF_OPTS = \
  12. --disable-rpath \
  13. --disable-debug \
  14. --with-conf-file=/etc/unbound/unbound.conf \
  15. --with-pidfile=/var/run/unbound.pid \
  16. --with-rootkey-file=/etc/unbound/root.key \
  17. --enable-tfo-server \
  18. --with-libexpat=$(STAGING_DIR)/usr \
  19. --with-ssl=$(STAGING_DIR)/usr
  20. # uClibc-ng does not have MSG_FASTOPEN
  21. # so TCP Fast Open client mode disabled for it
  22. ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
  23. UNBOUND_CONF_OPTS += --disable-tfo-client
  24. else
  25. UNBOUND_CONF_OPTS += --enable-tfo-client
  26. endif
  27. ifeq ($(BR2_TOOLCHAIN_HAS_THREADS_NPTL),y)
  28. UNBOUND_CONF_OPTS += --with-pthreads
  29. else
  30. UNBOUND_CONF_OPTS += --without-pthreads
  31. endif
  32. ifeq ($(BR2_GCC_ENABLE_LTO),y)
  33. UNBOUND_CONF_OPTS += --enable-flto
  34. else
  35. UNBOUND_CONF_OPTS += --disable-flto
  36. endif
  37. ifeq ($(BR2_PACKAGE_UNBOUND_DNSCRYPT),y)
  38. UNBOUND_CONF_OPTS += --enable-dnscrypt
  39. UNBOUND_DEPENDENCIES += libsodium
  40. else
  41. UNBOUND_CONF_OPTS += --disable-dnscrypt
  42. endif
  43. define UNBOUND_INSTALL_INIT_SYSV
  44. $(INSTALL) -D -m 755 package/unbound/S70unbound \
  45. $(TARGET_DIR)/etc/init.d/S70unbound
  46. endef
  47. $(eval $(autotools-package))