gcc.mk 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329
  1. ################################################################################
  2. #
  3. # Common variables for the gcc-initial and gcc-final packages.
  4. #
  5. ################################################################################
  6. #
  7. # Version, site and source
  8. #
  9. GCC_VERSION = $(call qstrip,$(BR2_GCC_VERSION))
  10. ifeq ($(BR2_GCC_VERSION_ARC),y)
  11. GCC_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,gcc,$(GCC_VERSION))
  12. GCC_SOURCE = gcc-$(GCC_VERSION).tar.gz
  13. else ifeq ($(BR2_GCC_VERSION_CSKY),y)
  14. GCC_SITE = $(call github,c-sky,gcc,$(GCC_VERSION))
  15. GCC_SOURCE = gcc-$(GCC_VERSION).tar.gz
  16. else
  17. GCC_SITE = $(BR2_GNU_MIRROR:/=)/gcc/gcc-$(GCC_VERSION)
  18. GCC_SOURCE = gcc-$(GCC_VERSION).tar.xz
  19. endif
  20. #
  21. # Xtensa special hook
  22. #
  23. define HOST_GCC_XTENSA_OVERLAY_EXTRACT
  24. $(call arch-xtensa-overlay-extract,$(@D),gcc)
  25. endef
  26. #
  27. # Apply patches
  28. #
  29. # gcc is a special package, not named gcc, but gcc-initial and
  30. # gcc-final, but patches are nonetheless stored in package/gcc in the
  31. # tree, and potentially in BR2_GLOBAL_PATCH_DIR directories as well.
  32. define HOST_GCC_APPLY_PATCHES
  33. for patchdir in \
  34. package/gcc/$(GCC_VERSION) \
  35. $(addsuffix /gcc/$(GCC_VERSION),$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) \
  36. $(addsuffix /gcc,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) ; do \
  37. if test -d $${patchdir}; then \
  38. $(APPLY_PATCHES) $(@D) $${patchdir} \*.patch || exit 1; \
  39. fi; \
  40. done
  41. $(HOST_GCC_APPLY_POWERPC_PATCH)
  42. endef
  43. HOST_GCC_EXCLUDES = \
  44. libjava/* libgo/*
  45. #
  46. # Create 'build' directory and configure symlink
  47. #
  48. define HOST_GCC_CONFIGURE_SYMLINK
  49. mkdir -p $(@D)/build
  50. ln -sf ../configure $(@D)/build/configure
  51. endef
  52. #
  53. # Common configuration options
  54. #
  55. HOST_GCC_COMMON_DEPENDENCIES = \
  56. host-binutils \
  57. host-gmp \
  58. host-mpc \
  59. host-mpfr \
  60. $(if $(BR2_BINFMT_FLAT),host-elf2flt)
  61. HOST_GCC_COMMON_CONF_OPTS = \
  62. --target=$(GNU_TARGET_NAME) \
  63. --with-sysroot=$(STAGING_DIR) \
  64. --enable-__cxa_atexit \
  65. --with-gnu-ld \
  66. --disable-libssp \
  67. --disable-multilib \
  68. --disable-decimal-float \
  69. --with-gmp=$(HOST_DIR) \
  70. --with-mpc=$(HOST_DIR) \
  71. --with-mpfr=$(HOST_DIR) \
  72. --with-pkgversion="Buildroot $(BR2_VERSION_FULL)" \
  73. --with-bugurl="http://bugs.buildroot.net/" \
  74. --without-zstd
  75. # Don't build documentation. It takes up extra space / build time,
  76. # and sometimes needs specific makeinfo versions to work
  77. HOST_GCC_COMMON_CONF_ENV = \
  78. MAKEINFO=missing
  79. GCC_COMMON_TARGET_CFLAGS = $(TARGET_CFLAGS)
  80. GCC_COMMON_TARGET_CXXFLAGS = $(TARGET_CXXFLAGS)
  81. # used to fix ../../../../libsanitizer/libbacktrace/../../libbacktrace/elf.c:772:21: error: 'st.st_mode' may be used uninitialized in this function [-Werror=maybe-uninitialized]
  82. ifeq ($(BR2_ENABLE_DEBUG),y)
  83. GCC_COMMON_TARGET_CFLAGS += -Wno-error
  84. endif
  85. # Propagate options used for target software building to GCC target libs
  86. HOST_GCC_COMMON_CONF_ENV += CFLAGS_FOR_TARGET="$(GCC_COMMON_TARGET_CFLAGS)"
  87. HOST_GCC_COMMON_CONF_ENV += CXXFLAGS_FOR_TARGET="$(GCC_COMMON_TARGET_CXXFLAGS)"
  88. # libitm needs sparc V9+
  89. ifeq ($(BR2_sparc_v8)$(BR2_sparc_leon3),y)
  90. HOST_GCC_COMMON_CONF_OPTS += --disable-libitm
  91. endif
  92. # libmpx uses secure_getenv and struct _libc_fpstate not present in musl
  93. ifeq ($(BR2_TOOLCHAIN_BUILDROOT_MUSL)$(BR2_TOOLCHAIN_GCC_AT_LEAST_6),yy)
  94. HOST_GCC_COMMON_CONF_OPTS += --disable-libmpx
  95. endif
  96. # quadmath support requires wchar
  97. ifeq ($(BR2_USE_WCHAR)$(BR2_TOOLCHAIN_HAS_LIBQUADMATH),yy)
  98. HOST_GCC_COMMON_CONF_OPTS += --enable-libquadmath
  99. else
  100. HOST_GCC_COMMON_CONF_OPTS += --disable-libquadmath
  101. endif
  102. # libsanitizer requires wordexp, not in default uClibc config. Also
  103. # doesn't build properly with musl.
  104. ifeq ($(BR2_TOOLCHAIN_BUILDROOT_UCLIBC)$(BR2_TOOLCHAIN_BUILDROOT_MUSL),y)
  105. HOST_GCC_COMMON_CONF_OPTS += --disable-libsanitizer
  106. endif
  107. # libsanitizer is broken for SPARC
  108. # https://bugs.busybox.net/show_bug.cgi?id=7951
  109. ifeq ($(BR2_sparc)$(BR2_sparc64),y)
  110. HOST_GCC_COMMON_CONF_OPTS += --disable-libsanitizer
  111. endif
  112. # The logic in libbacktrace/configure.ac to detect if __sync builtins
  113. # are available assumes they are as soon as target_subdir is not
  114. # empty, i.e when cross-compiling. However, some platforms do not have
  115. # __sync builtins, so help the configure script a bit.
  116. ifeq ($(BR2_TOOLCHAIN_HAS_SYNC_4),)
  117. HOST_GCC_COMMON_CONF_ENV += target_configargs="libbacktrace_cv_sys_sync=no"
  118. endif
  119. # TLS support is not needed on uClibc/no-thread and
  120. # uClibc/linux-threads, otherwise, for all other situations (glibc,
  121. # musl and uClibc/NPTL), we need it.
  122. ifeq ($(BR2_TOOLCHAIN_BUILDROOT_UCLIBC)$(BR2_PTHREADS)$(BR2_PTHREADS_NONE),yy)
  123. HOST_GCC_COMMON_CONF_OPTS += --disable-tls
  124. else
  125. HOST_GCC_COMMON_CONF_OPTS += --enable-tls
  126. endif
  127. ifeq ($(BR2_GCC_ENABLE_LTO),y)
  128. HOST_GCC_COMMON_CONF_OPTS += --enable-plugins --enable-lto
  129. endif
  130. ifeq ($(BR2_PTHREADS_NONE),y)
  131. HOST_GCC_COMMON_CONF_OPTS += \
  132. --disable-threads \
  133. --disable-libitm \
  134. --disable-libatomic
  135. else
  136. HOST_GCC_COMMON_CONF_OPTS += --enable-threads
  137. endif
  138. # gcc 5 doesn't need cloog any more, see
  139. # https://gcc.gnu.org/gcc-5/changes.html and we don't support graphite
  140. # on GCC 4.9.x, so only isl is needed.
  141. ifeq ($(BR2_GCC_ENABLE_GRAPHITE),y)
  142. HOST_GCC_COMMON_DEPENDENCIES += host-isl
  143. HOST_GCC_COMMON_CONF_OPTS += --with-isl=$(HOST_DIR)
  144. else
  145. HOST_GCC_COMMON_CONF_OPTS += --without-isl --without-cloog
  146. endif
  147. ifeq ($(BR2_arc),y)
  148. HOST_GCC_COMMON_DEPENDENCIES += host-flex host-bison
  149. endif
  150. ifeq ($(BR2_SOFT_FLOAT),y)
  151. # only mips*-*-*, arm*-*-* and sparc*-*-* accept --with-float
  152. # powerpc seems to be needing it as well
  153. ifeq ($(BR2_arm)$(BR2_armeb)$(BR2_mips)$(BR2_mipsel)$(BR2_mips64)$(BR2_mips64el)$(BR2_powerpc)$(BR2_sparc),y)
  154. HOST_GCC_COMMON_CONF_OPTS += --with-float=soft
  155. endif
  156. endif
  157. # Determine arch/tune/abi/cpu options
  158. ifneq ($(GCC_TARGET_ARCH),)
  159. HOST_GCC_COMMON_CONF_OPTS += --with-arch="$(GCC_TARGET_ARCH)"
  160. endif
  161. ifneq ($(GCC_TARGET_ABI),)
  162. HOST_GCC_COMMON_CONF_OPTS += --with-abi="$(GCC_TARGET_ABI)"
  163. endif
  164. ifeq ($(BR2_TOOLCHAIN_HAS_MNAN_OPTION),y)
  165. ifneq ($(GCC_TARGET_NAN),)
  166. HOST_GCC_COMMON_CONF_OPTS += --with-nan="$(GCC_TARGET_NAN)"
  167. endif
  168. endif
  169. ifneq ($(GCC_TARGET_FP32_MODE),)
  170. HOST_GCC_COMMON_CONF_OPTS += --with-fp-32="$(GCC_TARGET_FP32_MODE)"
  171. endif
  172. ifneq ($(GCC_TARGET_CPU),)
  173. HOST_GCC_COMMON_CONF_OPTS += --with-cpu=$(GCC_TARGET_CPU)
  174. endif
  175. ifneq ($(GCC_TARGET_FPU),)
  176. HOST_GCC_COMMON_CONF_OPTS += --with-fpu=$(GCC_TARGET_FPU)
  177. endif
  178. ifneq ($(GCC_TARGET_FLOAT_ABI),)
  179. HOST_GCC_COMMON_CONF_OPTS += --with-float=$(GCC_TARGET_FLOAT_ABI)
  180. endif
  181. ifneq ($(GCC_TARGET_MODE),)
  182. HOST_GCC_COMMON_CONF_OPTS += --with-mode=$(GCC_TARGET_MODE)
  183. endif
  184. # Enable proper double/long double for SPE ABI
  185. ifeq ($(BR2_powerpc_SPE),y)
  186. HOST_GCC_COMMON_CONF_OPTS += \
  187. --enable-e500_double \
  188. --with-long-double-128
  189. endif
  190. # Set default to Secure-PLT to prevent run-time
  191. # generation of PLT stubs (supports RELRO and
  192. # SELinux non-exemem capabilities)
  193. ifeq ($(BR2_powerpc),y)
  194. HOST_GCC_COMMON_CONF_OPTS += --enable-secureplt
  195. endif
  196. # PowerPC64 big endian by default uses the elfv1 ABI, and PowerPC 64
  197. # little endian by default uses the elfv2 ABI. However, musl has
  198. # decided to use the elfv2 ABI for both, so we force the elfv2 ABI for
  199. # Power64 big endian when the selected C library is musl.
  200. ifeq ($(BR2_TOOLCHAIN_USES_MUSL)$(BR2_powerpc64),yy)
  201. HOST_GCC_COMMON_CONF_OPTS += \
  202. --with-abi=elfv2 \
  203. --without-long-double-128
  204. endif
  205. # Since glibc >= 2.26, poerpc64le requires double/long double which
  206. # requires at least gcc 6.2.
  207. # See sysdeps/powerpc/powerpc64le/configure.ac
  208. ifeq ($(BR2_TOOLCHAIN_USES_GLIBC)$(BR2_TOOLCHAIN_GCC_AT_LEAST_6)$(BR2_powerpc64le),yyy)
  209. HOST_GCC_COMMON_CONF_OPTS += \
  210. --with-long-double-128
  211. endif
  212. ifeq ($(BR2_s390x),y)
  213. HOST_GCC_COMMON_CONF_OPTS += \
  214. --with-long-double-128
  215. endif
  216. HOST_GCC_COMMON_TOOLCHAIN_WRAPPER_ARGS += -DBR_CROSS_PATH_SUFFIX='".br_real"'
  217. # For gcc-initial, we need to tell gcc that the C library will be
  218. # providing the ssp support, as it can't guess it since the C library
  219. # hasn't been built yet.
  220. #
  221. # For gcc-final, the gcc logic to detect whether SSP support is
  222. # available or not in the C library is not working properly for
  223. # uClibc, so let's be explicit as well.
  224. HOST_GCC_COMMON_MAKE_OPTS = \
  225. gcc_cv_libc_provides_ssp=$(if $(BR2_TOOLCHAIN_HAS_SSP),yes,no)
  226. ifeq ($(BR2_CCACHE),y)
  227. HOST_GCC_COMMON_CCACHE_HASH_FILES += $(GCC_DL_DIR)/$(GCC_SOURCE)
  228. # Cfr. PATCH_BASE_DIRS in .stamp_patched, but we catch both versioned
  229. # and unversioned patches unconditionally. Moreover, to facilitate the
  230. # addition of gcc patches in BR2_GLOBAL_PATCH_DIR, we allow them to be
  231. # stored in a sub-directory called 'gcc' even if it's not technically
  232. # the name of the package.
  233. HOST_GCC_COMMON_CCACHE_HASH_FILES += \
  234. $(sort $(wildcard \
  235. package/gcc/$(GCC_VERSION)/*.patch \
  236. $(addsuffix /$($(PKG)_RAWNAME)/$(GCC_VERSION)/*.patch,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) \
  237. $(addsuffix /$($(PKG)_RAWNAME)/*.patch,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) \
  238. $(addsuffix /gcc/$(GCC_VERSION)/*.patch,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR))) \
  239. $(addsuffix /gcc/*.patch,$(call qstrip,$(BR2_GLOBAL_PATCH_DIR)))))
  240. ifeq ($(BR2_xtensa),y)
  241. HOST_GCC_COMMON_CCACHE_HASH_FILES += $(ARCH_XTENSA_OVERLAY_TAR)
  242. endif
  243. # _CONF_OPTS contains some references to the absolute path of $(HOST_DIR)
  244. # and a reference to the Buildroot git revision (BR2_VERSION_FULL),
  245. # so substitute those away.
  246. HOST_GCC_COMMON_TOOLCHAIN_WRAPPER_ARGS += -DBR_CCACHE_HASH=\"`\
  247. printf '%s\n' $(subst $(HOST_DIR),@HOST_DIR@,\
  248. $(subst --with-pkgversion="Buildroot $(BR2_VERSION_FULL)",,$($(PKG)_CONF_OPTS))) \
  249. | sha256sum - $(HOST_GCC_COMMON_CCACHE_HASH_FILES) \
  250. | cut -c -64 | tr -d '\n'`\"
  251. endif # BR2_CCACHE
  252. # The LTO support in gcc creates wrappers for ar, ranlib and nm which load
  253. # the lto plugin. These wrappers are called *-gcc-ar, *-gcc-ranlib, and
  254. # *-gcc-nm and should be used instead of the real programs when -flto is
  255. # used. However, we should not add the toolchain wrapper for them, and they
  256. # match the *cc-* pattern. Therefore, an additional case is added for *-ar,
  257. # *-ranlib and *-nm.
  258. # According to gfortran manpage, it supports all options supported by gcc, so
  259. # add gfortran to the list of the program called via the Buildroot wrapper.
  260. # Avoid that a .br_real is symlinked a second time.
  261. # Also create <arch>-linux-<tool> symlinks.
  262. define HOST_GCC_INSTALL_WRAPPER_AND_SIMPLE_SYMLINKS
  263. $(Q)cd $(HOST_DIR)/bin; \
  264. for i in $(GNU_TARGET_NAME)-*; do \
  265. case "$$i" in \
  266. *.br_real) \
  267. ;; \
  268. *-ar|*-ranlib|*-nm) \
  269. ln -snf $$i $(ARCH)-linux$${i##$(GNU_TARGET_NAME)}; \
  270. ;; \
  271. *cc|*cc-*|*++|*++-*|*cpp|*-gfortran|*-gdc) \
  272. rm -f $$i.br_real; \
  273. mv $$i $$i.br_real; \
  274. ln -sf toolchain-wrapper $$i; \
  275. ln -sf toolchain-wrapper $(ARCH)-linux$${i##$(GNU_TARGET_NAME)}; \
  276. ln -snf $$i.br_real $(ARCH)-linux$${i##$(GNU_TARGET_NAME)}.br_real; \
  277. ;; \
  278. *) \
  279. ln -snf $$i $(ARCH)-linux$${i##$(GNU_TARGET_NAME)}; \
  280. ;; \
  281. esac; \
  282. done
  283. endef
  284. include $(sort $(wildcard package/gcc/*/*.mk))