make.mk 928 B

12345678910111213141516171819202122232425262728293031
  1. ################################################################################
  2. #
  3. # make
  4. #
  5. ################################################################################
  6. MAKE_VERSION = 4.2.1
  7. MAKE_SOURCE = make-$(MAKE_VERSION).tar.bz2
  8. MAKE_SITE = $(BR2_GNU_MIRROR)/make
  9. MAKE_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES) host-pkgconf
  10. MAKE_LICENSE = GPL-3.0+
  11. MAKE_LICENSE_FILES = COPYING
  12. # Patching configure.ac
  13. MAKE_AUTORECONF = YES
  14. MAKE_CONF_OPTS = --without-guile
  15. # Disable the 'load' operation for static builds since it needs dlopen
  16. ifeq ($(BR2_STATIC_LIBS),y)
  17. MAKE_CONF_OPTS += --disable-load
  18. endif
  19. HOST_MAKE_DEPENDENCIES = host-pkgconf
  20. HOST_MAKE_CONF_OPTS = --without-guile
  21. # Configure host-make binary to be 'host-make' to ensure it isn't
  22. # accidently used by packages when they invoke recursive / sub-make.
  23. HOST_MAKE_CONF_OPTS += --program-prefix=host-
  24. $(eval $(autotools-package))
  25. $(eval $(host-autotools-package))