avrdude.mk 962 B

123456789101112131415161718192021222324252627282930
  1. ################################################################################
  2. #
  3. # avrdude
  4. #
  5. ################################################################################
  6. AVRDUDE_VERSION = eabe067c4527bc2eedc5db9288ef5cf1818ec720
  7. AVRDUDE_SITE = $(call github,kcuzner,avrdude,$(AVRDUDE_VERSION))
  8. AVRDUDE_LICENSE = GPLv2+
  9. AVRDUDR_LICENSE_FILES = avrdude/COPYING
  10. AVRDUDE_SUBDIR = avrdude
  11. # Sources coming from git, without generated configure and Makefile.in
  12. # files.
  13. AVRDUDE_AUTORECONF = YES
  14. AVRDUDE_DEPENDENCIES = libelf libusb libusb-compat ncurses \
  15. host-flex host-bison
  16. ifeq ($(BR2_PACKAGE_LIBFTDI),y)
  17. AVRDUDE_DEPENDENCIES += libftdi
  18. endif
  19. # if /etc/avrdude.conf exists, the installation process creates a
  20. # backup file, which we do not want in the context of Buildroot.
  21. define AVRDUDE_REMOVE_BACKUP_FILE
  22. $(RM) -f $(TARGET_DIR)/etc/avrdude.conf.bak
  23. endef
  24. AVRDUDE_POST_INSTALL_TARGET_HOOKS += AVRDUDE_REMOVE_BACKUP_FILE
  25. $(eval $(autotools-package))