wvstreams.mk 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. ################################################################################
  2. #
  3. # wvstreams
  4. #
  5. ################################################################################
  6. WVSTREAMS_VERSION = 4.6.1
  7. WVSTREAMS_SITE = http://wvstreams.googlecode.com/files
  8. WVSTREAMS_DEPENDENCIES = openssl zlib host-pkgconf
  9. WVSTREAMS_INSTALL_STAGING = YES
  10. WVSTREAMS_LICENSE = LGPLv2+
  11. WVSTREAMS_LICENSE_FILES = LICENSE
  12. # N.B. parallel make fails
  13. WVSTREAMS_MAKE = $(MAKE1)
  14. # Needed to work around problem with wvassert.h
  15. WVSTREAMS_CONF_OPTS += CPPFLAGS=-DNDEBUG
  16. WVSTREAMS_CONF_OPTS += \
  17. --with-openssl \
  18. --with-zlib \
  19. --without-pam \
  20. --disable-warnings \
  21. --without-tcl
  22. # needed for openssl detection when statically linking (as ssl needs lz)
  23. WVSTREAMS_CONF_ENV += LIBS=-lz
  24. ifneq ($(BR2_STATIC_LIBS),y)
  25. WVSTREAMS_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -fPIC"
  26. endif
  27. # wvstreams uses argp.h which can be provided by the argp-standalone
  28. # package
  29. ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
  30. WVSTREAMS_DEPENDENCIES += argp-standalone
  31. endif
  32. ifeq ($(BR2_PACKAGE_DBUS),y)
  33. WVSTREAMS_DEPENDENCIES += dbus
  34. WVSTREAMS_CONF_OPTS += --with-dbus
  35. else
  36. WVSTREAMS_CONF_OPTS += --without-dbus
  37. endif
  38. ifeq ($(BR2_PACKAGE_QT),y)
  39. WVSTREAMS_DEPENDENCIES += qt
  40. WVSTREAMS_CONF_OPTS += --with-qt
  41. else
  42. WVSTREAMS_CONF_OPTS += --without-qt
  43. endif
  44. ifeq ($(BR2_PACKAGE_VALGRIND),y)
  45. WVSTREAMS_DEPENDENCIES += valgrind
  46. WVSTREAMS_CONF_OPTS += --with-valgrind
  47. else
  48. WVSTREAMS_CONF_OPTS += --without-valgrind
  49. endif
  50. $(eval $(autotools-package))