skeleton.mk 656 B

1234567891011121314151617181920
  1. ################################################################################
  2. #
  3. # skeleton
  4. #
  5. ################################################################################
  6. # The skeleton can't depend on the toolchain, since all packages depends on the
  7. # skeleton and the toolchain is a target package, as is skeleton.
  8. # Hence, skeleton would depends on the toolchain and the toolchain would depend
  9. # on skeleton.
  10. SKELETON_ADD_TOOLCHAIN_DEPENDENCY = NO
  11. SKELETON_ADD_SKELETON_DEPENDENCY = NO
  12. ifeq ($(BR2_PACKAGE_SKELETON_CUSTOM),y)
  13. SKELETON_DEPENDENCIES = skeleton-custom
  14. else
  15. SKELETON_DEPENDENCIES = skeleton-common
  16. endif
  17. $(eval $(generic-package))