Browse Source

grub2: fix build with BR2_STRIP_none

grub2 assumes the strip command will generate output and the output should
always be stripped - so, just use the $(TARGET_CROSS)strip to make sure that
the build succeeds regardless of the buildroot strip configuration.

Signed-off-by: Charles Hardin <ckhardin@exablox.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Charles Hardin 8 years ago
parent
commit
fc174b7057
1 changed files with 4 additions and 1 deletions
  1. 4 1
      boot/grub2/grub2.mk

+ 4 - 1
boot/grub2/grub2.mk

@@ -45,6 +45,9 @@ endif
 # the confusion, it also uses NM, OBJCOPY and STRIP to build the
 # bootloader itself; none of these are used to build the native
 # tools.
+#
+# NOTE: TARGET_STRIP is overridden by BR2_STRIP_none, so always
+# use the cross compile variant to ensure grub2 builds
 
 GRUB2_CONF_ENV = \
 	$(HOST_CONFIGURE_OPTS) \
@@ -55,7 +58,7 @@ GRUB2_CONF_ENV = \
 	TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
 	NM="$(TARGET_NM)" \
 	OBJCOPY="$(TARGET_OBJCOPY)" \
-	STRIP="$(TARGET_STRIP)"
+	STRIP="$(TARGET_CROSS)strip"
 
 GRUB2_CONF_OPTS = \
 	--target=$(GRUB2_TARGET) \