Explorar el Código

package/most: new package

--with-slang has to be given explicitly, otherwise the configure script
looks for slang.h in host directories.

Signed-off-by: Sven Oliver Moll <svolli@svolli.de>
[Arnout: add --with-slang config option]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sven Oliver Moll hace 5 años
padre
commit
f40ceb857e
Se han modificado 5 ficheros con 46 adiciones y 0 borrados
  1. 3 0
      DEVELOPERS
  2. 1 0
      package/Config.in
  3. 12 0
      package/most/Config.in
  4. 6 0
      package/most/most.hash
  5. 24 0
      package/most/most.mk

+ 3 - 0
DEVELOPERS

@@ -2113,6 +2113,9 @@ F:	package/libmms/
 F:	package/orc/
 F:	package/wampcc/
 
+N:	Sven Oliver Moll <svolli@svolli.de>
+F:	package/most/
+
 N:	Theo Debrouwere <t.debrouwere@televic.com>
 F:	package/pugixml/
 

+ 1 - 0
package/Config.in

@@ -2231,6 +2231,7 @@ menu "Text editors and viewers"
 	source "package/joe/Config.in"
 	source "package/less/Config.in"
 	source "package/mc/Config.in"
+	source "package/most/Config.in"
 	source "package/nano/Config.in"
 	source "package/uemacs/Config.in"
 	source "package/vim/Config.in"

+ 12 - 0
package/most/Config.in

@@ -0,0 +1,12 @@
+config BR2_PACKAGE_MOST
+	bool "most"
+	depends on BR2_USE_MMU # slang
+	select BR2_PACKAGE_SLANG
+	help
+	  most is a powerful pager, including features like multi
+	  document support, hex view and unpack on-the-fly.
+
+	  https://www.jedsoft.com/most/
+
+	  Note: this program depends on the slang library which is
+	  rather large to be used just for this pager.

+ 6 - 0
package/most/most.hash

@@ -0,0 +1,6 @@
+# From https://www.jedsoft.org/releases/most/
+sha1 db811669a6b22c15478c957b439b5e4483ce1c95 most-5.1.0.tar.gz
+# Locally computed
+sha256 db805d1ffad3e85890802061ac8c90e3c89e25afb184a794e03715a3ed190501  most-5.1.0.tar.gz
+sha256 1b2a567f289f66a143c56353e7b3d4fa5862514a5e3c5cfdf8b02ee5e5aaa953  COPYING
+sha256 47ad1c3f9b94d6ec42d9bee6c5df980c5c2daa5b9d22113545ae6a3f21ca2f52  COPYRIGHT

+ 24 - 0
package/most/most.mk

@@ -0,0 +1,24 @@
+################################################################################
+#
+# most
+#
+################################################################################
+
+MOST_SITE = http://www.jedsoft.org/releases/most
+MOST_VERSION = 5.1.0
+MOST_LICENSE = GPL-2.0+
+MOST_LICENSE_FILES = COPYING COPYRIGHT
+MOST_DEPENDENCIES = slang
+
+MOST_CONF_OPTS = --with-slang=$(STAGING_DIR)/usr
+
+define MOST_REMOVE_LOCAL_SLANG_CHECK
+	$(SED) 's/ slangversion / /g' $(@D)/src/Makefile.in
+endef
+MOST_POST_PATCH_HOOKS += MOST_REMOVE_LOCAL_SLANG_CHECK
+
+define MOST_INSTALL_TARGET_CMDS
+	$(INSTALL) -D -m 0755 $(@D)/src/objs/most $(TARGET_DIR)/usr/bin/most
+endef
+
+$(eval $(autotools-package))