Explorar o código

linux-tools: add cpupower

This patch is based on the patch send by James Knight:
http://lists.busybox.net/pipermail/buildroot/2015-May/128754.html

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Cc: James Knight <james.knight@rockwellcollins.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Romain Naour %!s(int64=9) %!d(string=hai) anos
pai
achega
f1863ede94
Modificáronse 3 ficheiros con 53 adicións e 0 borrados
  1. 3 0
      linux/Config.in
  2. 11 0
      linux/Config.tools.in
  3. 39 0
      linux/linux-tool-cpupower.mk

+ 3 - 0
linux/Config.in

@@ -364,6 +364,9 @@ config BR2_LINUX_KERNEL_INSTALL_TARGET
 # Linux extensions
 source "linux/Config.ext.in"
 
+# Linux tools
+source "linux/Config.tools.in"
+
 endif # BR2_LINUX_KERNEL
 
 endmenu

+ 11 - 0
linux/Config.tools.in

@@ -0,0 +1,11 @@
+menu "Linux Kernel Tools"
+
+config BR2_LINUX_KERNEL_TOOL_CPUPOWER
+	bool "cpupower"
+	depends on !BR2_bfin # pciutils
+	select BR2_PACKAGE_PCIUTILS
+	help
+	  cpupower is a collection of tools to examine and tune power
+	  saving related features of your processor.
+
+endmenu

+ 39 - 0
linux/linux-tool-cpupower.mk

@@ -0,0 +1,39 @@
+################################################################################
+#
+# cpupower
+#
+################################################################################
+
+LINUX_TOOLS += cpupower
+
+CPUPOWER_DEPENDENCIES = pciutils
+
+CPUPOWER_MAKE_OPTS = CROSS=$(TARGET_CROSS) \
+	CPUFREQ_BENCH=false \
+	DEBUG=false
+
+define CPUPOWER_BUILD_CMDS
+	$(Q)if test ! -f $(@D)/tools/power/cpupower/Makefile ; then \
+		echo "Your kernel version is too old and does not have the cpupower tool." ; \
+		echo "At least kernel 3.4 must be used." ; \
+		exit 1 ; \
+	fi
+
+	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/tools \
+		$(CPUPOWER_MAKE_OPTS) \
+		cpupower
+endef
+
+define CPUPOWER_INSTALL_STAGING_CMDS
+	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/tools \
+		$(CPUPOWER_MAKE_OPTS) \
+		DESTDIR=$(STAGING_DIR) \
+		cpupower_install
+endef
+
+define CPUPOWER_INSTALL_TARGET_CMDS
+	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/tools \
+		$(CPUPOWER_MAKE_OPTS) \
+		DESTDIR=$(TARGET_DIR) \
+		cpupower_install
+endef