Browse Source

openvpn: Fix paths to external utilities

This sets paths to ifconfig, route, netstat and ip
in the target root filesystem.

Otherwise the paths leak from the host and may not
match those on the target.

Signed-off-by: Valentine Barshak <gvaxon@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Valentine Barshak 11 years ago
parent
commit
f02d58ccff
1 changed files with 10 additions and 1 deletions
  1. 10 1
      package/openvpn/openvpn.mk

+ 10 - 1
package/openvpn/openvpn.mk

@@ -6,7 +6,16 @@
 
 OPENVPN_VERSION = 2.2.2
 OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
-OPENVPN_CONF_OPT = --enable-small --disable-plugins
+OPENVPN_CONF_OPT = --enable-small --disable-plugins \
+			--with-ifconfig-path=/sbin/ifconfig \
+			--with-route-path=/sbin/route \
+			--with-netstat-path=/bin/netstat
+
+ifeq ($(BR2_PACKAGE_IPROUTE2),y)
+OPENVPN_CONF_OPT += --with-iproute-path=/sbin/ip
+else
+OPENVPN_CONF_OPT += --with-iproute-path=/bin/ip
+endif
 
 ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
 	OPENVPN_DEPENDENCIES += lzo